blob: 01a8e2f84b5136de28e2c31ee8974f4d993ec8c5 [file] [log] [blame]
Skyler Turner62330c12022-03-04 22:10:16 +00001{ config, pkgs, nixpkgs }:
2let
3 variables = import ./common/variables.nix;
4in {
5 import = [
6 ./apps/personal/steam.nix
7
8 ];
9
10 nixpkgs.overlays = [
11 (import ./overlays/anytype.nix)
12 ];
13
14 home.packages = with pkgs; [
15 anytype
16
17 minecraft
18 git-crypt gnupg pinentry_qt
19 spotify
20 keepassxc
21 grim slurp
22 neovim helix
23 qemu
24 bind
25 file
26 nur.repos.kira-bruneau.rofi-wayland
27 rofimoji
28 anytype-latest
29 htop
30 hue-cli
31 comma
32 zip
33 mindustry-alpha-wayland
34 nodejs-17_x
35 element
36 tdesktop
37 ]; # Use *only* for packages that need no configuration;
38 # other packages should go in ./apps/personal/
39
40 home.stateVersion = variables.stateVersion;
41}