blob: e9cfb760294657c070373e20469c32ea31d09ad2 [file] [log] [blame]
Skyler Turner62330c12022-03-04 22:10:16 +00001{ config, pkgs, nixpkgs }:
2let
3 variables = import ./common/variables.nix;
4 personalPackages =
5 let
6 toPkg = file: {
7 name = builtins.replaceStrings [ ".nix" ] [ "" ] file;
8 value = import (./. + "/pkgConfigs/${file}") { };
9 };
10 in
11 pkgs.lib.mapAttrs' toPkg (builtins.readDir (./. + "/pkgConfigs"));
12 in
13 { imports = generatedPkgs; }
14
15in {
16 import = [
17 ./apps/personal/steam.nix
18
19 ];
20
21 nixpkgs.overlays = [
22 (import ./overlays/anytype.nix)
23 ];
24
25 home.packages = with pkgs; [ # New apps should be on new lines
26 anytype
27 minecraft
28 nodejs-17_x
29
30 git-crypt gnupg pinentry_qt
31 keepassxc
32 grim slurp
33 neovim helix
34 qemu
35 bind
36 file
37 nur.repos.kira-bruneau.rofi-wayland
38 rofimoji
39 anytype-latest
40 htop
41 hue-cli
42 comma
43 zip
44 mindustry-alpha-wayland
45 element
46 tdesktop
47 ]; # Use *only* for packages that need no configuration;
48 # other packages should go in ./apps/personal/
49
50 home.stateVersion = variables.stateVersion;
51}