blob: 9a1f87f1cd0ae30d87061e0c3cc76184fcb4058b [file] [log] [blame]
Skyler Turner62330c12022-03-04 22:10:16 +00001{ config, pkgs, nixpkgs }:
2let
3 variables = import ./common/variables.nix;
4 personalPackages = let
5 toPkg = file: {
6 name = builtins.replaceStrings [ ".nix" ] [ "" ] file;
7 value = import (./. + "/pkgConfigs/${file}") { };
8 };
9 in
10 pkgs.lib.mapAttrs' toPkg (builtins.readDir (./. + "/pkgConfigs"));
11
12in {
13 import = [
14 ./apps/personal/steam.nix
15
16 ];
17
18 nixpkgs.overlays = [
19 (import ./overlays/anytype.nix)
20 ];
21
22 home.packages = with pkgs; [ # New apps should be on new lines
23 anytype
24 minecraft
25 nodejs-17_x
26
27 git-crypt gnupg pinentry_qt
28 keepassxc
29 grim slurp
30 neovim helix
31 qemu
32 bind
33 file
34 nur.repos.kira-bruneau.rofi-wayland
35 rofimoji
36 anytype-latest
37 htop
38 hue-cli
39 comma
40 zip
41 mindustry-alpha-wayland
42 element
43 tdesktop
44 ]; # Use *only* for packages that need no configuration;
45 # other packages should go in ./apps/personal/
46
47 home.stateVersion = variables.stateVersion;
48}