blob: cc58aa4ec44e5cfd17a18e0ba9e6ce4024a0754e [file] [log] [blame]
Skyler Turner62330c12022-03-04 22:10:16 +00001{ config, pkgs, nixpkgs }:
2let
3 variables = import ./common/variables.nix;
4 personalPackages = let
5 toPkg = file: {
6 name = builtins.replaceStrings [ ".nix" ] [ "" ] file;
7 value = import (./. + "/pkgConfigs/${file}") { };
8 };
9 in pkgs.lib.mapAttrs' toPkg (builtins.readDir (./. + "/pkgConfigs"));
10in {
11 import = [
12 ./apps/personal/steam.nix
13
14 ];
15
16 nixpkgs.overlays = [
17 (import ./overlays/anytype.nix)
18 ];
19
20 home.packages = with pkgs; [ # New apps should be on new lines
21 anytype
22 minecraft
23 nodejs-17_x
24
25 git-crypt gnupg pinentry_qt
26 keepassxc
27 grim slurp
28 neovim helix
29 qemu
30 bind
31 file
32 nur.repos.kira-bruneau.rofi-wayland
33 rofimoji
34 anytype-latest
35 htop
36 hue-cli
37 comma
38 zip
39 mindustry-alpha-wayland
40 element
41 tdesktop
42 ]; # Use *only* for packages that need no configuration;
43 # other packages should go in ./apps/personal/
44
45 home.stateVersion = variables.stateVersion;
46}