blob: 10f7dee9c4a3b69efca0c741db3bf98daf943ba3 [file] [log] [blame]
Skyler Grey29c15f12023-03-26 11:22:41 +00001{ pkgs, ... }: {
2 home = {
3 programs.kitty = {
4 enable = true;
5
6 theme = "One Half Dark";
7
8 settings = {
9 enable_audio_bell = "no";
10 visual_bell_duration = "0.1";
11 symbol_map = "U+E0A0-U+E0A3 PowerlineSymbols";
12 disable_ligatures = "cursor";
13 };
14 };
15 programs.zsh.initExtra = ''
16 if test -n "$KITTY_INSTALLATION_DIR"; then
17 export KITTY_SHELL_INTEGRATION="enabled"
18 autoload -Uz -- "$KITTY_INSTALLATION_DIR"/shell-integration/zsh/kitty-integration
19 kitty-integration
20 unfunction kitty-integration
21 fi
22 '';
23
24 home.shellAliases = {
25 icat = "${pkgs.kitty}/bin/kitty +kitten icat";
26 };
27 };
28}