Skyler Grey | b562da3 | 2022-09-01 23:36:28 +0100 | [diff] [blame] | 1 | {pkgs, ...}: let |
| 2 | config = { |
| 3 | left = { |
| 4 | enter_command = [./systemd-inhibit/inhibit-idle.sh]; |
| 5 | exit_command = [./systemd-inhibit/stop-inhibiting-idle.sh]; |
| 6 | locations = ["bottom_right" "bottom_left"]; |
| 7 | size = 10; |
| 8 | timeout_ms = 250; |
| 9 | }; |
| 10 | "left.output".description = ""; |
| 11 | }; |
| 12 | in { |
| 13 | home = { |
| 14 | home = { |
| 15 | packages = [pkgs.waycorner]; |
| 16 | file.".config/waycorner/config.toml".source = (pkgs.formats.toml {}).generate "config.toml" config; |
| 17 | }; |
| 18 | wayland.windowManager.sway.config.startup = [ |
| 19 | {command = "${pkgs.waycorner}/bin/waycorner";} |
| 20 | ]; |
| 21 | }; |
| 22 | } |