blob: 43d21900184982c533bbca3d27ccbbffb5cc36e1 [file] [log] [blame]
Skyler Greye6acc162022-10-31 00:19:37 +00001{
2 pkgs
3}: with pkgs; let
4 hash = "e82b59795985540062f4c00e582dc42e8b8358e8";
5in
6 stdenv.mkDerivation rec {
7 version = builtins.substring 0 7 hash;
8 src = builtins.fetchGit {
9 url = "https://github.com/KDE/kalgebra";
10 rev = hash;
11 };
12 name = "kalgebra-${version}";
13 nativeBuildInputs = [extra-cmake-modules qt5.wrapQtAppsHook];
14 buildInputs = with qt5; with libsForQt5; [
15 qtbase
16 qtquickcontrols
17 kconfig
18 kcoreaddons
19 kcrash
20 kconfigwidgets
21 kdbusaddons
22 kdoctools
23 ktextwidgets
24 kxmlgui
25 kdeApplications.libkdegames
26 kcompletion
27 analitza
28 kirigami2
29 ];
30 }