blob: 00e26e840530d681290ebd418b19c5830ff13a0a [file] [log] [blame]
Skyler Turner62330c12022-03-04 22:10:16 +00001{ config, pkgs, nixpkgs }:
2let
3 variables = import ./common/variables.nix;
4 personalPackages = let
5 toPkg = file: {
6 name = builtins.replaceStrings [ ".nix" ] [ "" ] file;
7 value = import (./. + "/pkgConfigs/${file}") { };
8 };
9 in
10 pkgs.lib.mapAttrs' toPkg (builtins.readDir (./. + "/pkgConfigs"));
11 in
12 { imports = generatedPkgs; }
13
14in {
15 import = [
16 ./apps/personal/steam.nix
17
18 ];
19
20 nixpkgs.overlays = [
21 (import ./overlays/anytype.nix)
22 ];
23
24 home.packages = with pkgs; [ # New apps should be on new lines
25 anytype
26 minecraft
27 nodejs-17_x
28
29 git-crypt gnupg pinentry_qt
30 keepassxc
31 grim slurp
32 neovim helix
33 qemu
34 bind
35 file
36 nur.repos.kira-bruneau.rofi-wayland
37 rofimoji
38 anytype-latest
39 htop
40 hue-cli
41 comma
42 zip
43 mindustry-alpha-wayland
44 element
45 tdesktop
46 ]; # Use *only* for packages that need no configuration;
47 # other packages should go in ./apps/personal/
48
49 home.stateVersion = variables.stateVersion;
50}