Skyler Grey | 68791c8 | 2022-10-31 00:26:04 +0000 | [diff] [blame] | 1 | { lib |
| 2 | , stdenv |
| 3 | , meson |
| 4 | , ninja |
| 5 | , fetchFromGitHub |
| 6 | }: |
| 7 | |
| 8 | stdenv.mkDerivation rec { |
| 9 | pname = "tomlplusplus"; |
| 10 | version = "3.2.0"; |
| 11 | |
| 12 | src = fetchFromGitHub { |
| 13 | owner = "marzer"; |
| 14 | repo = pname; |
| 15 | rev = "4b166b69f28e70a416a1a04a98f365d2aeb90de8"; |
| 16 | hash = "sha256-nohO4eySs73BSgjvq+uzybiE5lw2rFY5YqGbl/oqGek="; |
| 17 | }; |
| 18 | |
| 19 | nativeBuildInputs = [ meson ninja ]; |
| 20 | |
| 21 | meta = with lib;{ |
| 22 | homepage = "https://github.com/marzer/tomlplusplus"; |
| 23 | description = "Header-only TOML config file parser and serializer for C++17"; |
| 24 | license = licenses.mit; |
| 25 | maintainers = with maintainers; [ Scrumplex ]; |
| 26 | platforms = with platforms; unix; |
| 27 | }; |
| 28 | } |