blob: 73ef7e125d8797d385ed65c55ad86d459d2999f9 [file] [log] [blame]
Skyler Greybcb2cb72022-08-21 07:24:35 +01001{impermanence, ...}: {
Skyler Grey6aa7c262022-08-20 22:22:03 +01002 imports = [
3 impermanence.nixosModules.impermanence
4 ];
5
6 config = {
7 environment.persistence."/nix/persist" = {
8 hideMounts = true;
9 };
10
11 fileSystems."/" = {
12 device = "none";
13 fsType = "tmpfs";
14 options = ["defaults" "size=4G" "mode=755"];
15 };
Skyler Greyf4a835a2022-08-20 22:30:48 +010016
17 fileSystems."/boot" = {
18 device = "/dev/disk/by-label/boot";
19 fsType = "vfat";
20 };
21
22 fileSystems."/nix" = {
Skyler Greyff3c6a22022-08-21 07:25:02 +010023 device = "/dev/mapper/nix";
24 fsType = "ext4";
25 };
26
27 fileSystems."/large" = {
28 device = "/dev/mapper/hdd";
Skyler Greyf4a835a2022-08-20 22:30:48 +010029 fsType = "ext4";
30 };
31
32 swapDevices = [
Skyler Greyff3c6a22022-08-21 07:25:02 +010033 {device = "/dev/mapper/swap";}
Skyler Greyf4a835a2022-08-20 22:30:48 +010034 ];
Skyler Grey6aa7c262022-08-20 22:22:03 +010035 };
36}