blob: 2b522b306a8fe6dfefe238e67719f8639ae9e043 [file] [log] [blame]
{ config, lib, ... }:
{
options.chimera.editor.neovim = {
enable = lib.mkEnableOption "Enable neovim editor";
defaultEditor = lib.mkOption {
type = lib.types.bool;
description = "Use neovim as the default editor";
default = true;
};
# https://github.com/mrcjkb/kickstart-nix.nvim
};
config = lib.mkIf config.chimera.editor.neovim.enable {
programs.neovim = {
enable = true;
defaultEditor = config.chimera.editor.neovim.defaultEditor;
};
};
}