blob: 2b522b306a8fe6dfefe238e67719f8639ae9e043 [file] [log] [blame]
Samuel Shuert02ffd1e2024-02-13 21:37:15 -05001{ config, lib, ... }:
2{
3 options.chimera.editor.neovim = {
4 enable = lib.mkEnableOption "Enable neovim editor";
5 defaultEditor = lib.mkOption {
6 type = lib.types.bool;
7 description = "Use neovim as the default editor";
8 default = true;
9 };
Samuel Shuert659b5642024-02-23 20:47:43 +000010 # https://github.com/mrcjkb/kickstart-nix.nvim
Samuel Shuert02ffd1e2024-02-13 21:37:15 -050011 };
12
13 config = lib.mkIf config.chimera.editor.neovim.enable {
14 programs.neovim = {
15 enable = true;
16 defaultEditor = config.chimera.editor.neovim.defaultEditor;
17 };
18 };
19}