blob: 86bd9fc050807158a9ad56bf4014df66923b5efd [file] [log] [blame]
Skyler Grey4e230892024-02-13 22:58:46 +00001{ config, lib, ... }:
2{
3 options.chimera = {
Skyler Greycf116d52024-02-15 19:51:31 +00004 theme.wallpaper = lib.mkOption {
Skyler Grey4e230892024-02-13 22:58:46 +00005 type = lib.types.path;
6 description = "Wallpaper of your choosing";
7 };
8 hyprland.hyprpaper.splash = {
9 enable = lib.mkEnableOption "Enable the hyprland splash text";
10 offset = lib.mkOption {
11 type = lib.types.float;
12 description = "Set the splash offset";
13 default = 2.0;
14 };
15 };
16 };
Skyler Greya0da6b22024-02-11 22:53:41 +000017
Skyler Greyfa5455c2024-03-01 21:16:22 +000018 config.xdg.configFile = lib.mkIf config.chimera.hyprland.enable {
19 "hypr/hyprpaper.conf".source = (
20 builtins.toFile "hyprpaper.conf" ''
21 preload = ${config.chimera.theme.wallpaper}
Skyler Greya0da6b22024-02-11 22:53:41 +000022
Skyler Greyfa5455c2024-03-01 21:16:22 +000023 wallpaper=,${config.chimera.theme.wallpaper}
Skyler Grey4e230892024-02-13 22:58:46 +000024
PineaFan2f02bca2024-04-20 21:21:44 +010025 splash = ${if config.chimera.hyprland.hyprpaper.splash.enable then "true" else "false"}
Skyler Greyfa5455c2024-03-01 21:16:22 +000026 splash_offset = ${builtins.toString config.chimera.hyprland.hyprpaper.splash.offset}
Skyler Grey4e230892024-02-13 22:58:46 +000027
Skyler Greyfa5455c2024-03-01 21:16:22 +000028 ipc = off
29 ''
30 );
31 };
Skyler Greya0da6b22024-02-11 22:53:41 +000032}