blob: ca6d7094f127d41cfde74feb25c845fde4bf52de [file] [log] [blame]
Skyler Grey4e230892024-02-13 22:58:46 +00001{ config, lib, ... }:
2{
3 options.chimera = {
Skyler Greycf116d52024-02-15 19:51:31 +00004 theme.wallpaper = lib.mkOption {
Skyler Grey4e230892024-02-13 22:58:46 +00005 type = lib.types.path;
6 description = "Wallpaper of your choosing";
7 };
8 hyprland.hyprpaper.splash = {
9 enable = lib.mkEnableOption "Enable the hyprland splash text";
10 offset = lib.mkOption {
11 type = lib.types.float;
12 description = "Set the splash offset";
13 default = 2.0;
14 };
15 };
16 };
Skyler Greya0da6b22024-02-11 22:53:41 +000017
Skyler Grey4e230892024-02-13 22:58:46 +000018 config.xdg.configFile."hypr/hyprpaper.conf".source = lib.mkIf config.chimera.hyprland.enable (
19 builtins.toFile "hyprpaper.conf" ''
Skyler Greycf116d52024-02-15 19:51:31 +000020 preload = ${config.chimera.theme.wallpaper}
Skyler Greya0da6b22024-02-11 22:53:41 +000021
Skyler Greycf116d52024-02-15 19:51:31 +000022 wallpaper=,${config.chimera.theme.wallpaper}
Skyler Grey4e230892024-02-13 22:58:46 +000023
24 splash = ${builtins.toString config.chimera.hyprland.hyprpaper.splash.enable}
25 splash_offset = ${builtins.toString config.chimera.hyprland.hyprpaper.splash.offset}
26
27 ipc = off
28 ''
29 );
Skyler Greya0da6b22024-02-11 22:53:41 +000030}