Skyler Grey | 4e23089 | 2024-02-13 22:58:46 +0000 | [diff] [blame] | 1 | { config, lib, ... }: |
| 2 | { |
| 3 | options.chimera = { |
Skyler Grey | cf116d5 | 2024-02-15 19:51:31 +0000 | [diff] [blame] | 4 | theme.wallpaper = lib.mkOption { |
Skyler Grey | 4e23089 | 2024-02-13 22:58:46 +0000 | [diff] [blame] | 5 | type = lib.types.path; |
| 6 | description = "Wallpaper of your choosing"; |
| 7 | }; |
| 8 | hyprland.hyprpaper.splash = { |
| 9 | enable = lib.mkEnableOption "Enable the hyprland splash text"; |
| 10 | offset = lib.mkOption { |
| 11 | type = lib.types.float; |
| 12 | description = "Set the splash offset"; |
| 13 | default = 2.0; |
| 14 | }; |
| 15 | }; |
| 16 | }; |
Skyler Grey | a0da6b2 | 2024-02-11 22:53:41 +0000 | [diff] [blame] | 17 | |
Skyler Grey | 4e23089 | 2024-02-13 22:58:46 +0000 | [diff] [blame] | 18 | # TODO: wallpapers path[] -> gen wallpaper lines... |
| 19 | config.xdg.configFile."hypr/hyprpaper.conf".source = lib.mkIf config.chimera.hyprland.enable ( |
| 20 | builtins.toFile "hyprpaper.conf" '' |
Skyler Grey | cf116d5 | 2024-02-15 19:51:31 +0000 | [diff] [blame] | 21 | preload = ${config.chimera.theme.wallpaper} |
Skyler Grey | a0da6b2 | 2024-02-11 22:53:41 +0000 | [diff] [blame] | 22 | |
Skyler Grey | cf116d5 | 2024-02-15 19:51:31 +0000 | [diff] [blame] | 23 | wallpaper=,${config.chimera.theme.wallpaper} |
Skyler Grey | 4e23089 | 2024-02-13 22:58:46 +0000 | [diff] [blame] | 24 | |
| 25 | splash = ${builtins.toString config.chimera.hyprland.hyprpaper.splash.enable} |
| 26 | splash_offset = ${builtins.toString config.chimera.hyprland.hyprpaper.splash.offset} |
| 27 | |
| 28 | ipc = off |
| 29 | '' |
| 30 | ); |
Skyler Grey | a0da6b2 | 2024-02-11 22:53:41 +0000 | [diff] [blame] | 31 | } |