PineaFan | fd2f824 | 2024-04-20 20:51:36 +0100 | [diff] [blame] | 1 | { |
| 2 | # Snowfall Lib provides a customized `lib` instance with access to your flake's library |
| 3 | # as well as the libraries available from your flake's inputs. |
| 4 | lib, |
| 5 | # An instance of `pkgs` with your overlays and packages applied is also available. |
| 6 | pkgs, |
| 7 | # You also have access to your flake's inputs. |
| 8 | inputs, |
| 9 | |
| 10 | # Additional metadata is provided by Snowfall Lib. |
| 11 | home, # The home architecture for this host (eg. `x86_64-linux`). |
| 12 | target, # The Snowfall Lib target for this home (eg. `x86_64-home`). |
| 13 | format, # A normalized name for the home target (eg. `home`). |
| 14 | virtual, # A boolean to determine whether this home is a virtual target using nixos-generators. |
| 15 | host, # The host name for this home. |
| 16 | |
| 17 | # All other arguments come from the home home. |
| 18 | config, |
| 19 | ... |
| 20 | }: |
| 21 | { |
| 22 | programs.git.extraConfig.alias = { |
| 23 | graph = "log --graph --oneline --decorate"; |
| 24 | hash = "rev-parse HEAD"; |
| 25 | }; |
| 26 | |
| 27 | home.shellAliases = { |
| 28 | I-FUCKING-SAID-PULL = "f(){ git reset --hard origin/\"$@\"; unset -f f; }; f"; |
| 29 | mini = ''echo "you're using the wrong terminal"''; |
| 30 | }; |
| 31 | |
| 32 | programs.git.extraConfig.user = { |
| 33 | name = "PineaFan"; |
| 34 | signingkey = "8F50789F12AC6E6206EA870CE5E1C2D43B0E4AB3"; |
| 35 | }; |
| 36 | |
| 37 | home.packages = [ |
| 38 | pkgs.kate |
| 39 | pkgs.libsForQt5.kfind |
| 40 | pkgs.vlc |
| 41 | pkgs.obs-studio |
| 42 | pkgs.python312 |
| 43 | pkgs.playerctl |
| 44 | ]; |
| 45 | |
| 46 | programs.firefox.profiles.chimera.settings = { |
| 47 | "browser.startup.homepage" = "https://discord.com/app|https://matrix.clicks.codes"; |
| 48 | }; |
| 49 | |
| 50 | chimera = { |
| 51 | nextcloud.enable = true; |
| 52 | |
PineaFan | fd2f824 | 2024-04-20 20:51:36 +0100 | [diff] [blame] | 53 | theme.catppuccin = { |
| 54 | enable = true; |
| 55 | style = "Macchiato"; |
| 56 | color = "Mauve"; |
| 57 | }; |
| 58 | |
| 59 | browser.chromium = { |
| 60 | enable = true; |
| 61 | }; |
| 62 | |
| 63 | browser.firefox = { |
| 64 | enable = true; |
| 65 | extensions = { |
| 66 | youtube = { |
| 67 | sponsorBlock.enable = true; |
| 68 | returnDislike.enable = true; |
| 69 | deArrow.enable = true; |
| 70 | }; |
| 71 | adnauseam.enable = true; |
| 72 | }; |
| 73 | }; |
| 74 | |
| 75 | input.keybinds = { |
| 76 | alternativeSearch.enable = true; |
| 77 | extraBinds = [ |
| 78 | { |
| 79 | meta = "CTRL"; |
| 80 | key = "1"; |
| 81 | function = "exec, ${pkgs.pulseaudio}/bin/pactl set-default-sink $(${pkgs.pamixer}/bin/pamixer --list-sinks | grep \"Monitors\" | awk '{print $1}')"; |
| 82 | } |
| 83 | { |
| 84 | meta = "CTRL"; |
| 85 | key = "2"; |
| 86 | function = "exec, ${pkgs.pulseaudio}/bin/pactl set-default-sink $(${pkgs.pamixer}/bin/pamixer --list-sinks | grep \"Razer Kraken V3\" | awk '{print $1}')"; |
| 87 | } |
PineaFan | 8be65d8 | 2024-04-23 21:08:33 +0100 | [diff] [blame] | 88 | { |
| 89 | key = "F1"; |
| 90 | function = "exec, ~/Pictures/Wallpapers/change.sh light"; |
| 91 | } |
| 92 | { |
| 93 | key = "F2"; |
| 94 | function = "exec, ~/Pictures/Wallpapers/change.sh dark"; |
| 95 | } |
PineaFan | fd2f824 | 2024-04-20 20:51:36 +0100 | [diff] [blame] | 96 | ]; |
| 97 | }; |
| 98 | |
PineaFan | 8be65d8 | 2024-04-23 21:08:33 +0100 | [diff] [blame] | 99 | startupApplications = [ |
| 100 | "cd ~/Code/keyboard && python main.py" |
| 101 | ]; |
| 102 | |
PineaFan | fd2f824 | 2024-04-20 20:51:36 +0100 | [diff] [blame] | 103 | # input.mouse.scrolling.speedFactor = 0.45; |
| 104 | hyprland = { |
| 105 | hyprpaper.splash.enable = false; |
| 106 | enable = true; |
| 107 | monitors = [ |
PineaFan | 4a080ea | 2024-04-21 18:38:43 +0100 | [diff] [blame] | 108 | "DP-1,1920x1080@60,-1920x0,1" |
| 109 | "HDMI-A-1,1920x1080@75,0x0,1" |
| 110 | "DP-2,1920x1080@60,1920x0,1" |
PineaFan | fd2f824 | 2024-04-20 20:51:36 +0100 | [diff] [blame] | 111 | ]; |
| 112 | window = { |
| 113 | blur = 12; |
| 114 | rounding = 16; |
| 115 | }; |
| 116 | }; |
| 117 | |
| 118 | shell = { |
| 119 | zsh.enable = true; |
| 120 | # zsh.theme = "crunch"; |
| 121 | starship.enable = true; |
| 122 | |
| 123 | rebuildFlakePath = "/home/pinea/Code/NixFiles"; |
| 124 | |
| 125 | defaultAliases.enable = true; |
| 126 | usefulPackages.enable = true; |
| 127 | |
| 128 | replacements = { |
| 129 | defaultEnable = true; |
| 130 | atuin.enableUpArrow = true; |
| 131 | }; |
| 132 | }; |
| 133 | |
| 134 | theme.font.nerdFontGlyphs.enable = true; |
| 135 | theme.wallpaper = ./wallpaper.png; |
| 136 | |
| 137 | editor.nano = { |
| 138 | enable = true; |
| 139 | defaultEditor = false; |
| 140 | }; |
| 141 | |
| 142 | editor.neovim = { |
| 143 | enable = true; |
| 144 | defaultEditor = true; |
| 145 | }; |
| 146 | |
Samuel Shuert | 219cf0b | 2024-03-30 17:53:08 -0400 | [diff] [blame] | 147 | editor.editorconfig.enable = true; |
| 148 | |
PineaFan | fd2f824 | 2024-04-20 20:51:36 +0100 | [diff] [blame] | 149 | input.keyboard = { |
| 150 | layout = "gb"; |
| 151 | }; |
| 152 | |
| 153 | git = { |
| 154 | delta.enable = true; |
| 155 | gitReview.enable = true; |
| 156 | auth.clicksUsername = "pineafan"; |
| 157 | gpg.enable = true; |
PineaFan | 4a080ea | 2024-04-21 18:38:43 +0100 | [diff] [blame] | 158 | stgit.enable = true; |
PineaFan | fd2f824 | 2024-04-20 20:51:36 +0100 | [diff] [blame] | 159 | }; |
| 160 | |
| 161 | games = { |
| 162 | minecraft.enable = true; |
| 163 | # itch.enable = true; |
| 164 | }; |
| 165 | |
| 166 | yubikey.enable = true; |
| 167 | yubikey.pam.enable = true; |
| 168 | yubikey.pam.key = "pinea:ZY1C32oFgQxsKlJEccxdI6rcdC8cZU8gWnBHMRgwb+MVvbRRqdYVHkIlXokscurAi5s/iQ5jnngDXUwG103ajQ==,m9X/BEHiXM1CrXu1u2zvItbd/Qa/tQGAxhIuD2NB2ohwo5d+vODwYl2faUnLhxcJexOWYBHOAzyWwwoeVRQFJw==,es256,+presence"; |
| 169 | |
| 170 | waybar.modules.temperature.enable = true; |
| 171 | waybar.modules.temperature.hwmonPath = "/sys/class/hwmon/hwmon1/temp1_input"; |
| 172 | }; |
| 173 | |
| 174 | services.kdeconnect.enable = true; |
| 175 | |
| 176 | programs.zsh = { |
| 177 | initExtra = '' |
| 178 | ${pkgs.pridefetch}/bin/pridefetch -f nonbinary -a |
| 179 | ''; |
| 180 | }; |
| 181 | } |