blob: 214746e256664666909a1f8a32c42376a9a84d36 [file] [log] [blame]
Samuel Shuert02ffd1e2024-02-13 21:37:15 -05001{
2 config,
3 lib,
4 pkgs,
5 ...
6}:
7{
8 options.chimera.shell = {
9 rebuildFlakePath = lib.mkOption {
10 type = lib.types.nullOr lib.types.str;
11 description = "Full path to where you store your flake locally";
12 default = null;
13 };
14 defaultAliases.enable = lib.mkEnableOption "Use sensible custom aliases";
15 usefulPackages.enable = lib.mkEnableOption "Enable useful shell packages (ripgrep, wget, etc)";
16 replacements = {
Samuel Shuertf51d0492024-02-21 21:52:27 +000017 defaultEnable = lib.mkEnableOption "Enable replacing everything by default";
18
Samuel Shuertae46a692024-03-03 10:47:35 -050019 atuin = {
20 enable = lib.mkOption {
21 description = "Use atuin instead of bkd-i-search";
22 type = lib.types.bool;
23 default = config.chimera.shell.replacements.defaultEnable;
24 example = true;
25 };
26 enableUpArrow = lib.mkEnableOption "Pressing up arrow will enter atuin instead of scrolling back through history";
27 };
28
Samuel Shuertf51d0492024-02-21 21:52:27 +000029 eza.enable = lib.mkOption {
30 description = "Use eza instead of ls";
31 type = lib.types.bool;
32 default = config.chimera.shell.replacements.defaultEnable;
33 example = true;
34 };
35 bfs.enable = lib.mkOption {
36 description = "Use bfs instead of find";
37 type = lib.types.bool;
38 default = config.chimera.shell.replacements.defaultEnable;
39 example = true;
40 };
41 ripgrep.enable = lib.mkOption {
42 description = "Use ripgrep instead of grep";
43 type = lib.types.bool;
44 default = config.chimera.shell.replacements.defaultEnable;
45 example = true;
46 };
47 htop.enable = lib.mkOption {
48 description = "Use htop instead of top";
49 type = lib.types.bool;
50 default = config.chimera.shell.replacements.defaultEnable;
51 example = true;
52 };
53 erdtree.enable = lib.mkOption {
54 description = "Use erdtree instead of tree";
55 type = lib.types.bool;
56 default = config.chimera.shell.replacements.defaultEnable;
57 example = true;
58 };
59 dust.enable = lib.mkOption {
60 description = "Use dust instead of du";
61 type = lib.types.bool;
62 default = config.chimera.shell.replacements.defaultEnable;
63 example = true;
64 };
65 bat.enable = lib.mkOption {
66 description = "Use bat instead of cat";
67 type = lib.types.bool;
68 default = config.chimera.shell.replacements.defaultEnable;
69 example = true;
70 };
71 zoxide.enable = lib.mkOption {
72 description = "Use zoxide instead of cd";
73 type = lib.types.bool;
74 default = config.chimera.shell.replacements.defaultEnable;
75 example = true;
76 };
Samuel Shuert02ffd1e2024-02-13 21:37:15 -050077 };
78 };
79
80 config = {
81 home.shellAliases = lib.mkIf config.chimera.shell.defaultAliases.enable {
82 rebuild =
83 lib.mkIf (config.chimera.shell.rebuildFlakePath != null)
84 "sudo nixos-rebuild switch --flake ${config.chimera.shell.rebuildFlakePath}";
85 clr = "clear";
Skyler Grey1dea6b62024-03-12 11:41:15 +000086 edit = builtins.toString config.home.sessionVariables.EDITOR;
Skyler Greye3f77dc2024-02-25 13:17:34 +000087 find = lib.mkIf config.chimera.shell.replacements.bfs.enable "${pkgs.bfs}/bin/bfs";
Skyler Grey1ab2c1a2024-05-24 23:29:22 +000088 grep = lib.mkIf config.chimera.shell.replacements.ripgrep.enable "${config.programs.ripgrep.package}/bin/rg --include-zero";
Skyler Greye3f77dc2024-02-25 13:17:34 +000089 top = lib.mkIf config.chimera.shell.replacements.htop.enable "${config.programs.htop.package}/bin/htop";
90 tree = lib.mkIf config.chimera.shell.replacements.erdtree.enable "${pkgs.erdtree}/bin/erdtree";
91 du = lib.mkIf config.chimera.shell.replacements.dust.enable "${pkgs.dust}/bin/dust";
Samuel Shuertf51d0492024-02-21 21:52:27 +000092 cat = lib.mkIf config.chimera.shell.replacements.bat.enable "${pkgs.bat}/bin/bat";
Skyler Grey55d3edc2024-05-25 12:22:30 +000093
94 lix = "${config.nix.package}/bin/nix"; # Lix, like nix
Samuel Shuert02ffd1e2024-02-13 21:37:15 -050095 };
96
Skyler Greyb9fc2cd2024-04-05 09:10:39 +000097 home.sessionVariables = lib.mkIf (config.chimera.shell.usefulPackages.enable && config.chimera.theme.style == "Light") {
98 BAT_THEME = "OneHalfLight";
99 };
100
Samuel Shuertae46a692024-03-03 10:47:35 -0500101 programs.atuin = lib.mkIf config.chimera.shell.replacements.atuin.enable {
102 enable = true;
103 enableZshIntegration = config.chimera.shell.zsh.enable;
104 enableBashIntegration = config.chimera.shell.bash.enable;
105 flags = lib.mkIf (!config.chimera.shell.replacements.atuin.enableUpArrow) [ "--disable-up-arrow" ];
106 };
107
Samuel Shuertf51d0492024-02-21 21:52:27 +0000108 programs.eza = lib.mkIf config.chimera.shell.replacements.eza.enable {
109 enable = true;
Skyler Grey6b8b30c2024-04-20 22:20:37 +0000110 enableZshIntegration = config.chimera.shell.zsh.enable;
111 enableBashIntegration = config.chimera.shell.bash.enable;
Samuel Shuertf51d0492024-02-21 21:52:27 +0000112 };
113
114 programs.ripgrep = lib.mkIf config.chimera.shell.replacements.ripgrep.enable {
115 enable = true;
116 arguments = [ "--smart-case" ];
117 };
118
Samuel Shuert659b5642024-02-23 20:47:43 +0000119 programs.htop = lib.mkIf config.chimera.shell.replacements.htop.enable { enable = true; };
Samuel Shuertf51d0492024-02-21 21:52:27 +0000120
121 programs.zoxide = lib.mkIf config.chimera.shell.replacements.zoxide.enable {
122 enable = true;
123 enableZshIntegration = config.chimera.shell.zsh.enable;
124 enableBashIntegration = config.chimera.shell.bash.enable;
125 options = [ "--cmd cd" ];
126 };
127
128 programs.tealdeer = lib.mkIf config.chimera.shell.usefulPackages.enable {
Samuel Shuertf51d0492024-02-21 21:52:27 +0000129 enable = true;
Samuel Shuert32887872024-03-02 12:18:33 -0500130 settings.updates = {
131 auto_update = true;
132 auto_update_interval_hours = 72;
133 };
Samuel Shuert02ffd1e2024-02-13 21:37:15 -0500134 };
Samuel Shuert659b5642024-02-23 20:47:43 +0000135 programs.jq = lib.mkIf config.chimera.shell.usefulPackages.enable { enable = true; };
Samuel Shuert02ffd1e2024-02-13 21:37:15 -0500136
137 home.packages =
138 (
139 if config.chimera.shell.usefulPackages.enable then
140 [
141 pkgs.wget
Skyler Greyb9fc2cd2024-04-05 09:10:39 +0000142 pkgs.bat
Samuel Shuert02ffd1e2024-02-13 21:37:15 -0500143 pkgs.curl
144 pkgs.curlie
145 pkgs.pv
146 pkgs.sd
147 pkgs.tokei
148 pkgs.hyperfine
Samuel Shuertf51d0492024-02-21 21:52:27 +0000149 pkgs.tmux
Samuel Shuert02ffd1e2024-02-13 21:37:15 -0500150 ]
151 else
152 [ ]
153 )
Samuel Shuert02ffd1e2024-02-13 21:37:15 -0500154 ++ (if config.chimera.shell.replacements.bfs.enable then [ pkgs.bfs ] else [ ])
Samuel Shuert02ffd1e2024-02-13 21:37:15 -0500155 ++ (if config.chimera.shell.replacements.htop.enable then [ pkgs.htop ] else [ ])
156 ++ (if config.chimera.shell.replacements.erdtree.enable then [ pkgs.erdtree ] else [ ])
Skyler Greyb9fc2cd2024-04-05 09:10:39 +0000157 ++ (if config.chimera.shell.replacements.dust.enable then [ pkgs.dust ] else [ ]);
Samuel Shuert02ffd1e2024-02-13 21:37:15 -0500158 };
159}