blob: 3581d37ec419b82bbc39fa226387c07f2b631303 [file] [log] [blame]
Skyler Grey57f6b782024-03-13 14:43:09 +00001{
2 inputs,
3 lib,
4 gtimelog,
5 glib-networking,
6 gtk3,
7 libsoup,
8 glib,
9 pango,
10 harfbuzz,
11 gdk-pixbuf,
12 atk,
13 libsecret,
14 gobject-introspection,
15 ...
16}:
17gtimelog.overrideAttrs (oldAttrs: {
18 src = inputs.collabora-gtimelog;
19 makeWrapperArgs = [
20 "--set GIO_MODULE_DIR ${lib.makeSearchPathOutput "out" "lib/gio/modules" [ glib-networking ]}"
21 "--set GI_TYPELIB_PATH ${
22 lib.makeSearchPathOutput "out" "lib/girepository-1.0" [
23 gtk3
24 libsoup
25 glib
26 pango
27 harfbuzz
28 gdk-pixbuf
29 atk
30 libsecret
31 ]
32 }"
33 ];
34 buildInputs = oldAttrs.buildInputs ++ [ glib-networking ];
35 nativeBuildInputs = oldAttrs.nativeBuildInputs ++ [ gobject-introspection ];
36 preInstall = ''
37 cp ${inputs.collabora-icon} src/gtimelog/gtimelog-large.png
38 '';
39})