blob: 7edc711221fc9540966e285f595137fc81e3c33c [file] [log] [blame]
Samuel Shuertd58fbaf2024-06-20 21:08:48 -04001{
2 # Snowfall Lib provides a customized `lib` instance with access to your flake's library
3 # as well as the libraries available from your flake's inputs.
4 lib,
5 # An instance of `pkgs` with your overlays and packages applied is also available.
6 pkgs,
7 # You also have access to your flake's inputs.
8 inputs,
9
10 # Additional metadata is provided by Snowfall Lib.
11 home, # The home architecture for this host (eg. `x86_64-linux`).
12 target, # The Snowfall Lib target for this home (eg. `x86_64-home`).
13 format, # A normalized name for the home target (eg. `home`).
14 virtual, # A boolean to determine whether this home is a virtual target using nixos-generators.
15 host, # The host name for this home.
16
17 # All other arguments come from the home home.
18 config,
19 ...
20}:
21{
22 chimera.users.coded.enable = true;
23
24 chimera.waybar.modules = {
25 laptop.enable = true;
26 temperature.hwmonPath = "/sys/class/hwmon/hwmon4/temp1_input";
27 };
28
29 chimera.niri = {
30 enable = true;
31
32 monitors = {
33 "eDP-1" = {
34 mode = {
35 width = 2560;
36 height = 1600;
37 refresh = 165.;
38 };
39 position = {
40 x = 0;
41 y = 0;
42 };
43 };
44 };
45 };
46
Samuel Shuertc407eef2024-06-28 19:31:11 -040047 programs.ssh = {
48 enable = true;
49
50 includes = [ "~/.ssh/config.d/*" ];
51
52 matchBlocks = {
Samuel Shuert61647a92024-06-29 14:17:21 -040053 "github.com" = {
54 user = "git";
55 identityFile = [ "~/.ssh/OnTheGo5cResident" ];
Samuel Shuertc407eef2024-06-28 19:31:11 -040056 };
57 "greylag.minion" = {
58 identityFile = [ "~/.ssh/OnTheGo5cResident" ];
59 };
60 "shorthair" = {
61 identityFile = [ "~/.ssh/OnTheGo5cResident" ];
62 };
Samuel Shuert61647a92024-06-29 14:17:21 -040063 "git.auxolotl.org" = {
64 user = "forgejo";
65 identityFile = [ "~/.ssh/OnTheGo5cResident" ];
66 };
Samuel Shuertc407eef2024-06-28 19:31:11 -040067 };
68 };
69
Samuel Shuertd58fbaf2024-06-20 21:08:48 -040070 chimera.theme.wallpaper = ./wallpaper.png;
71}