Skyler Grey | 4e23089 | 2024-02-13 22:58:46 +0000 | [diff] [blame] | 1 | { |
| 2 | # Snowfall Lib provides a customized `lib` instance with access to your flake's library |
| 3 | # as well as the libraries available from your flake's inputs. |
| 4 | lib, |
| 5 | # An instance of `pkgs` with your overlays and packages applied is also available. |
| 6 | pkgs, |
| 7 | # You also have access to your flake's inputs. |
| 8 | inputs, |
| 9 | |
| 10 | # Additional metadata is provided by Snowfall Lib. |
| 11 | home, # The home architecture for this host (eg. `x86_64-linux`). |
| 12 | target, # The Snowfall Lib target for this home (eg. `x86_64-home`). |
| 13 | format, # A normalized name for the home target (eg. `home`). |
| 14 | virtual, # A boolean to determine whether this home is a virtual target using nixos-generators. |
| 15 | host, # The host name for this home. |
| 16 | |
| 17 | # All other arguments come from the home home. |
| 18 | config, |
| 19 | ... |
| 20 | }: |
| 21 | { |
| 22 | chimera = { |
Samuel Shuert | 02ffd1e | 2024-02-13 21:37:15 -0500 | [diff] [blame] | 23 | shell = { |
| 24 | rebuildFlakePath = "/home/coded/Documents/programming/nix/Personal"; |
| 25 | }; |
| 26 | |
Skyler Grey | 4e23089 | 2024-02-13 22:58:46 +0000 | [diff] [blame] | 27 | hyprland = { |
| 28 | enable = true; |
| 29 | |
| 30 | monitors = [ |
| 31 | "DP-1,1920x1080@165,0x0,1" |
| 32 | "DP-2,1920x1080@165,1920x0,1" |
| 33 | "HDMI-A-1,1920x1080@60,960x-1080,1" |
| 34 | ]; |
| 35 | |
| 36 | hyprpaper = { |
| 37 | splash = { |
| 38 | enable = true; |
| 39 | offset = -0.6; |
| 40 | }; |
| 41 | }; |
| 42 | }; |
| 43 | wallpaper = ./wallpaper.png; |
| 44 | |
| 45 | browser = { |
| 46 | firefox = { |
| 47 | enable = true; |
Samuel Shuert | 02ffd1e | 2024-02-13 21:37:15 -0500 | [diff] [blame] | 48 | extraExtensions = [ config.nur.repos.rycee.firefox-addons.simple-tab-groups ]; |
Skyler Grey | 4e23089 | 2024-02-13 22:58:46 +0000 | [diff] [blame] | 49 | }; |
| 50 | |
| 51 | chromium = { |
| 52 | enable = true; |
| 53 | extensions = { |
| 54 | bitwarden.enable = true; |
| 55 | youtube = { |
| 56 | sponsorBlock.enable = true; |
| 57 | returnDislike.enable = true; |
| 58 | deArrow.enable = true; |
| 59 | }; |
| 60 | reactdevtools.enable = true; |
| 61 | ublockOrigin.enable = true; |
| 62 | }; |
| 63 | extraExtensions = [ |
Samuel Shuert | 02ffd1e | 2024-02-13 21:37:15 -0500 | [diff] [blame] | 64 | { id = "gmkiokemhjjdjmpnnjmnpkpfoenpnpne"; } # Lofi Girl |
| 65 | { id = "bmnlcjabgnpnenekpadlanbbkooimhnj"; } # PayPal Honey |
| 66 | { id = "kekjfbackdeiabghhcdklcdoekaanoel"; } # MAL Sync |
Skyler Grey | 4e23089 | 2024-02-13 22:58:46 +0000 | [diff] [blame] | 67 | ]; |
| 68 | }; |
| 69 | }; |
| 70 | |
| 71 | theme.catppuccin = { |
| 72 | enable = true; |
| 73 | style = "Macchiato"; |
| 74 | color = "Blue"; |
| 75 | }; |
| 76 | }; |
| 77 | } |