blob: 6abbbe438c92b48f1e1b6ebefd51b72234463431 [file] [log] [blame]
Skyler Greya0da6b22024-02-11 22:53:41 +00001{ lib, config, ... }: {
2 options.minion.touchpadGestures.enable = lib.mkEnableOption "Enable touchpad gestures";
3
4 config = lib.mkIf config.minion.touchpadGestures.enable {
5 services.fusuma.enable = true;
6
7 systemd.user.startServices = "sd-switch";
8
9 systemd.user.services.fusuma.Unit.X-Restart-Triggers = [ config.xdg.configFile."fusuma/config.yaml".source ];
10 };
11}