blob: 5dbbcdc5ecebfdd4c3fb39d5711a7aa16bb20f0a [file] [log] [blame]
Skyler Greya0da6b22024-02-11 22:53:41 +00001{
Skyler Grey4e230892024-02-13 22:58:46 +00002 # Snowfall Lib provides a customized `lib` instance with access to your flake's library
3 # as well as the libraries available from your flake's inputs.
4 lib,
5 # An instance of `pkgs` with your overlays and packages applied is also available.
6 pkgs,
7 # You also have access to your flake's inputs.
8 inputs,
Skyler Greya0da6b22024-02-11 22:53:41 +00009
Skyler Grey4e230892024-02-13 22:58:46 +000010 # Additional metadata is provided by Snowfall Lib.
11 home, # The home architecture for this host (eg. `x86_64-linux`).
12 target, # The Snowfall Lib target for this home (eg. `x86_64-home`).
13 format, # A normalized name for the home target (eg. `home`).
14 virtual, # A boolean to determine whether this home is a virtual target using nixos-generators.
15 host, # The host name for this home.
Skyler Greya0da6b22024-02-11 22:53:41 +000016
Skyler Grey4e230892024-02-13 22:58:46 +000017 # All other arguments come from the home home.
18 config,
19 ...
Skyler Greya0da6b22024-02-11 22:53:41 +000020}:
21{
Skyler Greya2c02ac2024-03-01 21:10:17 +000022 chimera.minion.enable = true;
23
24 chimera.waybar = {
25 modules.temperature.hwmonPath = "/sys/class/hwmon/hwmon4/temp1_input";
26 modules.laptop.enable = true;
27 };
28
29 chimera.hyprland.enable = true;
30 chimera.hyprland.hyprpaper.splash.enable = true;
31 chimera.touchpad.enable = true;
32
33 chimera.hyprland.monitors = [
34 "eDP-1,preferred,0x0,1"
35 "desc:Dell Inc. DELL P2715Q V7WP95AV914L,preferred,2256x-1956,1,transform,1"
36 "desc:AOC 2460G5 0x00023C3F,preferred,336x-1080,1"
Skyler Grey0c5b0fc2024-03-03 15:38:44 +000037 ];
38
Skyler Greya2c02ac2024-03-01 21:10:17 +000039 chimera.theme.wallpaper = ./wallpaper.png;
Skyler Grey4bb9fb32024-02-24 12:23:36 +000040
Skyler Greya2c02ac2024-03-01 21:10:17 +000041 chimera.games = {
42 minecraft.enable = true;
43 itch.enable = true;
Skyler Grey4e230892024-02-13 22:58:46 +000044 };
Skyler Greya0da6b22024-02-11 22:53:41 +000045}