Skyler Grey | 4e23089 | 2024-02-13 22:58:46 +0000 | [diff] [blame] | 1 | { |
| 2 | # Snowfall Lib provides a customized `lib` instance with access to your flake's library |
| 3 | # as well as the libraries available from your flake's inputs. |
| 4 | lib, |
| 5 | # An instance of `pkgs` with your overlays and packages applied is also available. |
| 6 | pkgs, |
| 7 | # You also have access to your flake's inputs. |
| 8 | inputs, |
| 9 | |
| 10 | # Additional metadata is provided by Snowfall Lib. |
| 11 | home, # The home architecture for this host (eg. `x86_64-linux`). |
| 12 | target, # The Snowfall Lib target for this home (eg. `x86_64-home`). |
| 13 | format, # A normalized name for the home target (eg. `home`). |
| 14 | virtual, # A boolean to determine whether this home is a virtual target using nixos-generators. |
| 15 | host, # The host name for this home. |
| 16 | |
| 17 | # All other arguments come from the home home. |
| 18 | config, |
| 19 | ... |
| 20 | }: |
| 21 | { |
Samuel Shuert | cc979af | 2024-06-20 21:07:22 -0400 | [diff] [blame] | 22 | chimera.users.coded.enable = true; |
Samuel Shuert | 6d47eef | 2024-05-25 14:01:31 -0400 | [diff] [blame] | 23 | |
Samuel Shuert | cc979af | 2024-06-20 21:07:22 -0400 | [diff] [blame] | 24 | chimera.waybar.modules.temperature.hwmonPath = "/sys/class/hwmon/hwmon4/temp1_input"; |
Samuel Shuert | 6d47eef | 2024-05-25 14:01:31 -0400 | [diff] [blame] | 25 | |
Samuel Shuert | cc979af | 2024-06-20 21:07:22 -0400 | [diff] [blame] | 26 | chimera.niri = { |
| 27 | enable = true; |
Samuel Shuert | dab963e | 2024-03-23 19:54:28 -0400 | [diff] [blame] | 28 | |
Samuel Shuert | cc979af | 2024-06-20 21:07:22 -0400 | [diff] [blame] | 29 | monitors = { |
Samuel Shuert | e36c26b | 2024-10-07 22:16:22 -0400 | [diff] [blame^] | 30 | "DP-1" = { |
Samuel Shuert | 4345980 | 2024-10-06 13:46:52 -0400 | [diff] [blame] | 31 | mode = { |
| 32 | width = 3840; |
| 33 | height = 2160; |
Samuel Shuert | e36c26b | 2024-10-07 22:16:22 -0400 | [diff] [blame^] | 34 | refresh = 144.; |
Samuel Shuert | 4345980 | 2024-10-06 13:46:52 -0400 | [diff] [blame] | 35 | }; |
| 36 | position = { |
Samuel Shuert | cc979af | 2024-06-20 21:07:22 -0400 | [diff] [blame] | 37 | x = 0; |
| 38 | y = 0; |
| 39 | }; |
Skyler Grey | 4cd2e0a | 2024-02-15 19:59:19 +0000 | [diff] [blame] | 40 | }; |
Samuel Shuert | e36c26b | 2024-10-07 22:16:22 -0400 | [diff] [blame^] | 41 | "DP-2" = { |
| 42 | mode = { |
| 43 | width = 3840; |
| 44 | height = 2160; |
| 45 | refresh = 144.; |
| 46 | }; |
| 47 | position = { |
| 48 | x = 3840; |
| 49 | y = 0; |
| 50 | }; |
| 51 | }; |
Samuel Shuert | 4345980 | 2024-10-06 13:46:52 -0400 | [diff] [blame] | 52 | "Dell Inc. DELL S2422HG BTTCK83" = { |
Samuel Shuert | cc979af | 2024-06-20 21:07:22 -0400 | [diff] [blame] | 53 | mode = { |
| 54 | width = 1920; |
| 55 | height = 1080; |
Samuel Shuert | e36c26b | 2024-10-07 22:16:22 -0400 | [diff] [blame^] | 56 | refresh = 164.997; |
Samuel Shuert | 4d5c5fb | 2024-06-09 09:39:11 -0400 | [diff] [blame] | 57 | }; |
Samuel Shuert | cc979af | 2024-06-20 21:07:22 -0400 | [diff] [blame] | 58 | position = { |
Samuel Shuert | e36c26b | 2024-10-07 22:16:22 -0400 | [diff] [blame^] | 59 | x = -1920; |
| 60 | y = 540; |
Samuel Shuert | 4d5c5fb | 2024-06-09 09:39:11 -0400 | [diff] [blame] | 61 | }; |
Samuel Shuert | cc979af | 2024-06-20 21:07:22 -0400 | [diff] [blame] | 62 | }; |
Samuel Shuert | 4345980 | 2024-10-06 13:46:52 -0400 | [diff] [blame] | 63 | "LG Electronics LG TV SSCR2 0x01010101" = { |
Samuel Shuert | cc979af | 2024-06-20 21:07:22 -0400 | [diff] [blame] | 64 | mode = { |
| 65 | width = 3840; |
| 66 | height = 2160; |
| 67 | refresh = 60.; |
| 68 | }; |
| 69 | position = { |
| 70 | x = 0; |
| 71 | y = -2160; |
Samuel Shuert | 4d5c5fb | 2024-06-09 09:39:11 -0400 | [diff] [blame] | 72 | }; |
Skyler Grey | 4e23089 | 2024-02-13 22:58:46 +0000 | [diff] [blame] | 73 | }; |
| 74 | }; |
Skyler Grey | 4e23089 | 2024-02-13 22:58:46 +0000 | [diff] [blame] | 75 | }; |
Samuel Shuert | 30eebdf | 2024-02-29 17:26:35 -0500 | [diff] [blame] | 76 | |
Samuel Shuert | cc979af | 2024-06-20 21:07:22 -0400 | [diff] [blame] | 77 | chimera.theme.wallpaper = ./wallpaper.png; |
Samuel Shuert | 6cc9e6d | 2024-03-01 17:14:04 -0500 | [diff] [blame] | 78 | |
Samuel Shuert | cc979af | 2024-06-20 21:07:22 -0400 | [diff] [blame] | 79 | # SSH Config |
| 80 | programs.ssh = { |
| 81 | enable = true; |
Samuel Shuert | 30eebdf | 2024-02-29 17:26:35 -0500 | [diff] [blame] | 82 | |
Samuel Shuert | cc979af | 2024-06-20 21:07:22 -0400 | [diff] [blame] | 83 | includes = [ "~/.ssh/config.d/*" ]; |
| 84 | |
| 85 | matchBlocks = { |
Samuel Shuert | cc979af | 2024-06-20 21:07:22 -0400 | [diff] [blame] | 86 | "github.com" = { |
| 87 | user = "git"; |
Samuel Shuert | 61647a9 | 2024-06-29 14:17:21 -0400 | [diff] [blame] | 88 | identityFile = [ "~/.ssh/ShorthairNanoResident" "~/.ssh/OnTheGo5cResident" ]; |
Samuel Shuert | cc979af | 2024-06-20 21:07:22 -0400 | [diff] [blame] | 89 | }; |
Samuel Shuert | 61647a9 | 2024-06-29 14:17:21 -0400 | [diff] [blame] | 90 | "greylag.minion" = { |
| 91 | identityFile = [ "~/.ssh/ShorthairNanoResident" "~/.ssh/OnTheGo5cResident" ]; |
| 92 | }; |
| 93 | "ocicat" = { |
| 94 | identityFile = [ "~/.ssh/ShorthairNanoResident" "~/.ssh/OnTheGo5cResident" ]; |
| 95 | }; |
| 96 | "git.auxolotl.org" = { |
| 97 | user = "forgejo"; |
| 98 | identityFile = [ "~/.ssh/ShorthairNanoResident" "~/.ssh/OnTheGo5cResident" ]; |
Samuel Shuert | edbbcc3 | 2024-06-27 15:36:45 -0400 | [diff] [blame] | 99 | }; |
Samuel Shuert | 30eebdf | 2024-02-29 17:26:35 -0500 | [diff] [blame] | 100 | }; |
Samuel Shuert | cc979af | 2024-06-20 21:07:22 -0400 | [diff] [blame] | 101 | }; |
Skyler Grey | 4e23089 | 2024-02-13 22:58:46 +0000 | [diff] [blame] | 102 | } |