blob: 653983f7b900a61c2bb0719827184af4bd07ce1f [file] [log] [blame]
Skyler Grey4e230892024-02-13 22:58:46 +00001{
2 # Snowfall Lib provides a customized `lib` instance with access to your flake's library
3 # as well as the libraries available from your flake's inputs.
4 lib,
5 # An instance of `pkgs` with your overlays and packages applied is also available.
6 pkgs,
7 # You also have access to your flake's inputs.
8 inputs,
9
10 # Additional metadata is provided by Snowfall Lib.
11 home, # The home architecture for this host (eg. `x86_64-linux`).
12 target, # The Snowfall Lib target for this home (eg. `x86_64-home`).
13 format, # A normalized name for the home target (eg. `home`).
14 virtual, # A boolean to determine whether this home is a virtual target using nixos-generators.
15 host, # The host name for this home.
16
17 # All other arguments come from the home home.
18 config,
19 ...
20}:
21{
Samuel Shuertcc979af2024-06-20 21:07:22 -040022 chimera.users.coded.enable = true;
Samuel Shuert6d47eef2024-05-25 14:01:31 -040023
Samuel Shuertcc979af2024-06-20 21:07:22 -040024 chimera.waybar.modules.temperature.hwmonPath = "/sys/class/hwmon/hwmon4/temp1_input";
Samuel Shuert6d47eef2024-05-25 14:01:31 -040025
Samuel Shuertcc979af2024-06-20 21:07:22 -040026 chimera.niri = {
27 enable = true;
Samuel Shuertdab963e2024-03-23 19:54:28 -040028
Samuel Shuertcc979af2024-06-20 21:07:22 -040029 monitors = {
Samuel Shuerte36c26b2024-10-07 22:16:22 -040030 "DP-1" = {
Samuel Shuert43459802024-10-06 13:46:52 -040031 mode = {
32 width = 3840;
33 height = 2160;
Samuel Shuerte36c26b2024-10-07 22:16:22 -040034 refresh = 144.;
Samuel Shuert43459802024-10-06 13:46:52 -040035 };
36 position = {
Samuel Shuertcc979af2024-06-20 21:07:22 -040037 x = 0;
38 y = 0;
39 };
Skyler Grey4cd2e0a2024-02-15 19:59:19 +000040 };
Samuel Shuerte36c26b2024-10-07 22:16:22 -040041 "DP-2" = {
42 mode = {
43 width = 3840;
44 height = 2160;
45 refresh = 144.;
46 };
47 position = {
48 x = 3840;
49 y = 0;
50 };
51 };
Samuel Shuert43459802024-10-06 13:46:52 -040052 "Dell Inc. DELL S2422HG BTTCK83" = {
Samuel Shuertcc979af2024-06-20 21:07:22 -040053 mode = {
54 width = 1920;
55 height = 1080;
Samuel Shuerte36c26b2024-10-07 22:16:22 -040056 refresh = 164.997;
Samuel Shuert4d5c5fb2024-06-09 09:39:11 -040057 };
Samuel Shuertcc979af2024-06-20 21:07:22 -040058 position = {
Samuel Shuerte36c26b2024-10-07 22:16:22 -040059 x = -1920;
60 y = 540;
Samuel Shuert4d5c5fb2024-06-09 09:39:11 -040061 };
Samuel Shuertcc979af2024-06-20 21:07:22 -040062 };
Samuel Shuert43459802024-10-06 13:46:52 -040063 "LG Electronics LG TV SSCR2 0x01010101" = {
Samuel Shuertcc979af2024-06-20 21:07:22 -040064 mode = {
65 width = 3840;
66 height = 2160;
67 refresh = 60.;
68 };
69 position = {
70 x = 0;
71 y = -2160;
Samuel Shuert4d5c5fb2024-06-09 09:39:11 -040072 };
Skyler Grey4e230892024-02-13 22:58:46 +000073 };
74 };
Skyler Grey4e230892024-02-13 22:58:46 +000075 };
Samuel Shuert30eebdf2024-02-29 17:26:35 -050076
Samuel Shuertcc979af2024-06-20 21:07:22 -040077 chimera.theme.wallpaper = ./wallpaper.png;
Samuel Shuert6cc9e6d2024-03-01 17:14:04 -050078
Samuel Shuertcc979af2024-06-20 21:07:22 -040079 # SSH Config
80 programs.ssh = {
81 enable = true;
Samuel Shuert30eebdf2024-02-29 17:26:35 -050082
Samuel Shuertcc979af2024-06-20 21:07:22 -040083 includes = [ "~/.ssh/config.d/*" ];
84
85 matchBlocks = {
Samuel Shuertcc979af2024-06-20 21:07:22 -040086 "github.com" = {
87 user = "git";
Samuel Shuert61647a92024-06-29 14:17:21 -040088 identityFile = [ "~/.ssh/ShorthairNanoResident" "~/.ssh/OnTheGo5cResident" ];
Samuel Shuertcc979af2024-06-20 21:07:22 -040089 };
Samuel Shuert61647a92024-06-29 14:17:21 -040090 "greylag.minion" = {
91 identityFile = [ "~/.ssh/ShorthairNanoResident" "~/.ssh/OnTheGo5cResident" ];
92 };
93 "ocicat" = {
94 identityFile = [ "~/.ssh/ShorthairNanoResident" "~/.ssh/OnTheGo5cResident" ];
95 };
96 "git.auxolotl.org" = {
97 user = "forgejo";
98 identityFile = [ "~/.ssh/ShorthairNanoResident" "~/.ssh/OnTheGo5cResident" ];
Samuel Shuertedbbcc32024-06-27 15:36:45 -040099 };
Samuel Shuert30eebdf2024-02-29 17:26:35 -0500100 };
Samuel Shuertcc979af2024-06-20 21:07:22 -0400101 };
Skyler Grey4e230892024-02-13 22:58:46 +0000102}