blob: 5687e7254a05b4e7380ce6cbe798477733515271 [file] [log] [blame]
Skyler Grey453b9992023-03-05 05:48:42 +00001{
2 description = "A basic flake with a shell";
3 inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
4 inputs.flake-utils.url = "github:numtide/flake-utils";
5
6 outputs = { self, nixpkgs, flake-utils }:
7 flake-utils.lib.eachDefaultSystem (system: let
8 pkgs = nixpkgs.legacyPackages.${system};
9 in {
10 devShells.default = pkgs.mkShell {
Skyler Greycf771402023-03-05 07:06:37 +000011 packages = [ pkgs.yarn pkgs.nodejs-19_x pkgs.typescript ];
Skyler Grey453b9992023-03-05 05:48:42 +000012 };
13 });
14}