Skyler Grey | 8e4e183 | 2022-10-21 23:28:39 +0100 | [diff] [blame] | 1 | { |
2 | description = "A basic flake with a shell"; | ||||
3 | inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable"; | ||||
4 | inputs.flake-utils.url = "github:numtide/flake-utils"; | ||||
5 | |||||
6 | outputs = { self, nixpkgs, flake-utils }: | ||||
7 | flake-utils.lib.eachDefaultSystem (system: let | ||||
8 | pkgs = nixpkgs.legacyPackages.${system}; | ||||
9 | in { | ||||
10 | devShells.default = pkgs.mkShell { | ||||
11 | nativeBuildInputs = with pkgs; [yarn nodejs-18_x]; | ||||
12 | buildInputs = [ ]; | ||||
13 | }; | ||||
14 | }); | ||||
15 | } |