blob: 6c861fb91f6d5414fe119b82c784c449f97509ee [file] [log] [blame]
Samuel Shuertf1d6e992023-11-24 17:28:33 -05001# Do not modify this file! It was generated by ‘nixos-generate-config’
2# and may be overwritten by future invocations. Please make changes
3# to /etc/nixos/configuration.nix instead.
4{ config, lib, pkgs, modulesPath, ... }:
5
6{
7 imports = [ (modulesPath + "/installer/scan/not-detected.nix") ];
8
9 boot.initrd.availableKernelModules =
10 [ "nvme" "xhci_pci" "ahci" "usb_storage" "usbhid" "sd_mod" "sr_mod" ];
Samuel Shuerted2a3362024-01-25 21:56:10 -050011 boot.initrd.kernelModules = [ "amdgpu" ];
12 boot.kernelModules = [ ];
Samuel Shuertf1d6e992023-11-24 17:28:33 -050013 boot.extraModulePackages = [ ];
14
15 fileSystems."/" = {
16 device = "/dev/disk/by-uuid/63caf2b5-90d4-49a7-99e9-98dcdd797859";
17 fsType = "ext4";
18 };
19
20 boot.initrd.luks.devices."luks-c38bc921-8979-4a25-9520-f3354dee3557".device =
21 "/dev/disk/by-uuid/c38bc921-8979-4a25-9520-f3354dee3557";
22
23 fileSystems."/boot" = {
24 device = "/dev/disk/by-uuid/5B78-4B2D";
25 fsType = "vfat";
26 };
27
28 swapDevices =
29 [{ device = "/dev/disk/by-uuid/3a9212d4-6c39-4d5b-abf0-49294bd991c9"; }];
30
31 # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
32 # (the default) this is the recommended approach. When using systemd-networkd it's
33 # still possible to use this option, but it's recommended to use it in conjunction
34 # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
35 networking.useDHCP = lib.mkDefault true;
36 # networking.interfaces.enp42s0.useDHCP = lib.mkDefault true;
37 # networking.interfaces.wlo1.useDHCP = lib.mkDefault true;
38
39 nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
40 hardware.cpu.amd.updateMicrocode =
41 lib.mkDefault config.hardware.enableRedistributableFirmware;
42}