blob: 4e169ce3f95cd001277359f9d10c71c5528b0934 [file] [log] [blame]
# SPDX-FileCopyrightText: 2024 Clicks Codes
#
# SPDX-License-Identifier: GPL-3.0-only
{
config,
lib,
pkgs,
...
}:
{
options = {
clicks.users.deployers = lib.mkOption {
type = lib.types.listOf lib.types.str;
default = [ ];
description = "Users who should be allowed to deploy to this server. They will be given passwordless access to run commands as root";
};
};
}