blob: 4e169ce3f95cd001277359f9d10c71c5528b0934 [file] [log] [blame]
Skyler Greyf08a6192024-06-01 23:55:20 +00001# SPDX-FileCopyrightText: 2024 Clicks Codes
2#
3# SPDX-License-Identifier: GPL-3.0-only
4
5{
6 config,
7 lib,
8 pkgs,
9 ...
10}:
11{
12 options = {
13 clicks.users.deployers = lib.mkOption {
14 type = lib.types.listOf lib.types.str;
15 default = [ ];
16 description = "Users who should be allowed to deploy to this server. They will be given passwordless access to run commands as root";
17 };
18 };
19}