Skyler Grey | 1e2187f | 2023-03-03 22:45:10 +0000 | [diff] [blame] | 1 | # Do not modify this file! It was generated by ‘nixos-generate-config’ |
| 2 | # and may be overwritten by future invocations. Please make changes |
| 3 | # to /etc/nixos/configuration.nix instead. |
| 4 | { config, lib, pkgs, ... }: |
| 5 | |
| 6 | { |
| 7 | boot.initrd.availableKernelModules = [ "nvme" "xhci_pci" "ahci" "usbhid" "sd_mod" ]; |
| 8 | boot.initrd.kernelModules = [ ]; |
| 9 | boot.kernelModules = [ "kvm-amd" ]; |
| 10 | boot.extraModulePackages = [ ]; |
| 11 | |
| 12 | fileSystems."/" = |
Skyler Grey | 4f3e606 | 2023-03-04 01:29:29 +0000 | [diff] [blame^] | 13 | { |
| 14 | device = "/dev/disk/by-uuid/33e79acf-16a4-4263-be79-792c9432568c"; |
Skyler Grey | 1e2187f | 2023-03-03 22:45:10 +0000 | [diff] [blame] | 15 | fsType = "ext4"; |
| 16 | }; |
| 17 | |
| 18 | fileSystems."/boot" = |
Skyler Grey | 4f3e606 | 2023-03-04 01:29:29 +0000 | [diff] [blame^] | 19 | { |
| 20 | device = "/dev/disk/by-uuid/4EB3-743A"; |
Skyler Grey | 1e2187f | 2023-03-03 22:45:10 +0000 | [diff] [blame] | 21 | fsType = "vfat"; |
| 22 | }; |
| 23 | |
| 24 | swapDevices = |
Skyler Grey | 4f3e606 | 2023-03-04 01:29:29 +0000 | [diff] [blame^] | 25 | [{ device = "/dev/disk/by-uuid/3f3ddaa2-80c8-4915-83fe-fcec42bb877c"; }]; |
Skyler Grey | 1e2187f | 2023-03-03 22:45:10 +0000 | [diff] [blame] | 26 | |
| 27 | # Enables DHCP on each ethernet and wireless interface. In case of scripted networking |
| 28 | # (the default) this is the recommended approach. When using systemd-networkd it's |
| 29 | # still possible to use this option, but it's recommended to use it in conjunction |
| 30 | # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`. |
| 31 | networking.useDHCP = lib.mkDefault true; |
| 32 | # networking.interfaces.enp5s0.useDHCP = lib.mkDefault true; |
| 33 | |
| 34 | nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux"; |
| 35 | hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware; |
| 36 | } |