Skyler Grey | 1e2187f | 2023-03-03 22:45:10 +0000 | [diff] [blame] | 1 | # Do not modify this file! It was generated by ‘nixos-generate-config’ |
| 2 | # and may be overwritten by future invocations. Please make changes |
| 3 | # to /etc/nixos/configuration.nix instead. |
| 4 | { config, lib, pkgs, ... }: |
| 5 | |
| 6 | { |
Skyler Grey | fe1740c | 2023-10-21 01:24:18 +0000 | [diff] [blame] | 7 | boot.initrd.availableKernelModules = |
| 8 | [ "nvme" "xhci_pci" "ahci" "usbhid" "sd_mod" ]; |
Skyler Grey | 1e2187f | 2023-03-03 22:45:10 +0000 | [diff] [blame] | 9 | boot.initrd.kernelModules = [ ]; |
| 10 | boot.kernelModules = [ "kvm-amd" ]; |
| 11 | boot.extraModulePackages = [ ]; |
| 12 | |
Skyler Grey | fe1740c | 2023-10-21 01:24:18 +0000 | [diff] [blame] | 13 | fileSystems."/" = { |
| 14 | device = "/dev/disk/by-uuid/33e79acf-16a4-4263-be79-792c9432568c"; |
| 15 | fsType = "ext4"; |
| 16 | }; |
Skyler Grey | 1e2187f | 2023-03-03 22:45:10 +0000 | [diff] [blame] | 17 | |
Skyler Grey | fe1740c | 2023-10-21 01:24:18 +0000 | [diff] [blame] | 18 | fileSystems."/boot" = { |
| 19 | device = "/dev/disk/by-uuid/4EB3-743A"; |
| 20 | fsType = "vfat"; |
| 21 | }; |
Skyler Grey | 1e2187f | 2023-03-03 22:45:10 +0000 | [diff] [blame] | 22 | |
| 23 | swapDevices = |
Skyler Grey | 4f3e606 | 2023-03-04 01:29:29 +0000 | [diff] [blame] | 24 | [{ device = "/dev/disk/by-uuid/3f3ddaa2-80c8-4915-83fe-fcec42bb877c"; }]; |
Skyler Grey | 1e2187f | 2023-03-03 22:45:10 +0000 | [diff] [blame] | 25 | |
| 26 | # Enables DHCP on each ethernet and wireless interface. In case of scripted networking |
| 27 | # (the default) this is the recommended approach. When using systemd-networkd it's |
| 28 | # still possible to use this option, but it's recommended to use it in conjunction |
| 29 | # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`. |
| 30 | networking.useDHCP = lib.mkDefault true; |
| 31 | # networking.interfaces.enp5s0.useDHCP = lib.mkDefault true; |
| 32 | |
| 33 | nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux"; |
Skyler Grey | fe1740c | 2023-10-21 01:24:18 +0000 | [diff] [blame] | 34 | hardware.cpu.amd.updateMicrocode = |
| 35 | lib.mkDefault config.hardware.enableRedistributableFirmware; |
Skyler Grey | 1e2187f | 2023-03-03 22:45:10 +0000 | [diff] [blame] | 36 | } |