blob: 569d2b442b5ef661c4883a823cb7007b32f91154 [file] [log] [blame]
Skyler Greya78aa672023-05-20 13:48:18 +02001{ lib, config, ... }: let
2 cfg = config.scalpel;
3in {
4 system.activationScripts.scalpelCreateStore.text = lib.mkForce ''
5 echo "[scalpel] Ensuring existance of ${cfg.secretsDir}"
6 mkdir -p ${cfg.secretsDir}
7 grep -q "${cfg.secretsDir} ramfs" /proc/mounts || mount -t ramfs none "${cfg.secretsDir}" -o nodev,nosuid,mode=0751
8
9 echo "[scalpel] Clearing old secrets from ${cfg.secretsDir}"
10 find '${cfg.secretsDir}' -wholename '${cfg.secretsDir}' -o -prune -exec rm -rf -- {} +
11 '';
12}