blob: 21c5261d90696311599688c7c11ccd3bb2bf0d49 [file] [log] [blame]
Skyler Greydf6a6362024-08-08 22:07:15 +00001{ lib
2, python3
3, clicks
4}: let
5 pname = "beancount_share";
6 version = "0.1.10";
7in python3.pkgs.buildPythonApplication {
8 inherit pname version;
9
10 src = python3.pkgs.fetchPypi {
11 inherit pname version;
12 sha256 = "sha256-fnbdzijt/kCi4sUxCf2IPkpCjdwz9cZyCOJyQTAKkaY=";
13 };
14
15 format = "pyproject";
16
17 propagatedBuildInputs = [
18 python3.pkgs.beancount
19 clicks.beancount-beancount_plugin_utils
20 ];
21
22 buildInputs = [
23 python3.pkgs.setuptools
24 python3.pkgs.pdm-pep517
25 ];
26
27 meta = {
28 homepage = "https://github.com/Akuukis/beancount_share";
29 description = "A beancount plugin to share expenses with external partners within one ledger.";
30 license = lib.licenses.agpl3Only;
31 maintainers = [ lib.maintainers.minion3665 ];
32 };
33}