Skyler Grey | 1e2187f | 2023-03-03 22:45:10 +0000 | [diff] [blame] | 1 | { |
| 2 | description = "A flake to deploy and configure Clicks' NixOS server"; |
| 3 | |
Skyler Grey | 07584fb | 2023-05-01 21:37:13 +0000 | [diff] [blame] | 4 | inputs.nixpkgs.url = "github:nixos/nixpkgs/nixos-22.11"; |
Skyler Grey | a7fbaee | 2023-05-12 00:29:20 +0000 | [diff] [blame] | 5 | inputs.nixpkgs-unstable.url = "github:nixos/nixpkgs/nixpkgs-unstable"; |
Skyler Grey | 061574c | 2023-05-01 21:39:24 +0000 | [diff] [blame] | 6 | inputs.flake-utils.url = "github:numtide/flake-utils"; |
Skyler Grey | 1e2187f | 2023-03-03 22:45:10 +0000 | [diff] [blame] | 7 | inputs.deploy-rs.url = "github:serokell/deploy-rs"; |
Skyler Grey | 07584fb | 2023-05-01 21:37:13 +0000 | [diff] [blame] | 8 | inputs.home-manager.url = "github:nix-community/home-manager/release-22.11"; |
Skyler Grey | a7fbaee | 2023-05-12 00:29:20 +0000 | [diff] [blame] | 9 | inputs.sops-nix.url = "github:Mic92/sops-nix"; |
Skyler Grey | a78aa67 | 2023-05-20 13:48:18 +0200 | [diff] [blame^] | 10 | inputs.scalpel.url = "github:polygon/scalpel"; |
Skyler Grey | 1e2187f | 2023-03-03 22:45:10 +0000 | [diff] [blame] | 11 | |
Skyler Grey | fed0bb1 | 2023-05-01 21:42:03 +0000 | [diff] [blame] | 12 | inputs.home-manager.inputs.nixpkgs.follows = "nixpkgs"; |
| 13 | inputs.home-manager.inputs.utils.follows = "deploy-rs/utils"; |
| 14 | |
Skyler Grey | a7fbaee | 2023-05-12 00:29:20 +0000 | [diff] [blame] | 15 | inputs.sops-nix.inputs.nixpkgs.follows = "nixpkgs"; |
| 16 | |
Skyler Grey | a78aa67 | 2023-05-20 13:48:18 +0200 | [diff] [blame^] | 17 | inputs.scalpel.inputs.nixpkgs.follows = "nixpkgs"; |
| 18 | inputs.scalpel.inputs.sops-nix.follows = "sops-nix"; |
| 19 | |
| 20 | outputs = { self, nixpkgs, deploy-rs, home-manager, sops-nix, scalpel, nixpkgs-unstable, ... }@inputs: |
Skyler Grey | 07584fb | 2023-05-01 21:37:13 +0000 | [diff] [blame] | 21 | let |
| 22 | system = "x86_64-linux"; |
| 23 | pkgs = import nixpkgs { |
| 24 | inherit system; |
| 25 | config.allowUnfree = true; |
| 26 | }; |
Skyler Grey | a7fbaee | 2023-05-12 00:29:20 +0000 | [diff] [blame] | 27 | pkgs-unstable = import nixpkgs-unstable { |
| 28 | inherit system; |
| 29 | config.allowUnfree = true; |
| 30 | }; |
Skyler Grey | 07584fb | 2023-05-01 21:37:13 +0000 | [diff] [blame] | 31 | in |
| 32 | { |
| 33 | nixosConfigurations.clicks = |
Skyler Grey | a78aa67 | 2023-05-20 13:48:18 +0200 | [diff] [blame^] | 34 | let |
| 35 | base = nixpkgs.lib.nixosSystem { |
| 36 | inherit system pkgs; |
| 37 | modules = [ |
| 38 | ./default/configuration.nix |
| 39 | ./default/hardware-configuration.nix |
| 40 | ./modules/caddy.nix |
| 41 | ./modules/clamav.nix |
| 42 | ./modules/code-server.nix |
| 43 | ./modules/dmarc.nix |
| 44 | ./modules/dnsmasq.nix |
| 45 | ./modules/doas.nix |
| 46 | ./modules/docker.nix |
| 47 | ./modules/ecryptfs.nix |
| 48 | ./modules/fail2ban.nix |
| 49 | ./modules/fuck.nix |
| 50 | ./modules/git.nix |
| 51 | ./modules/grafana.nix |
| 52 | ./modules/home-manager-users.nix |
| 53 | ./modules/kitty.nix |
| 54 | ./modules/matrix.nix |
| 55 | ./modules/mongodb.nix |
| 56 | ./modules/node.nix |
| 57 | ./modules/postgres.nix |
| 58 | ./modules/samba.nix |
| 59 | ./modules/scalpel.nix |
| 60 | ./modules/tesseract.nix |
| 61 | sops-nix.nixosModules.sops |
| 62 | { |
| 63 | users.mutableUsers = false; |
| 64 | _module.args = { inherit pkgs-unstable; }; |
| 65 | } |
| 66 | ]; |
| 67 | specialArgs = { base = null; }; |
| 68 | }; |
| 69 | in |
| 70 | base.extendModules { |
Skyler Grey | 07584fb | 2023-05-01 21:37:13 +0000 | [diff] [blame] | 71 | modules = [ |
Skyler Grey | a78aa67 | 2023-05-20 13:48:18 +0200 | [diff] [blame^] | 72 | scalpel.nixosModules.scalpel |
Skyler Grey | 07584fb | 2023-05-01 21:37:13 +0000 | [diff] [blame] | 73 | ]; |
Skyler Grey | a78aa67 | 2023-05-20 13:48:18 +0200 | [diff] [blame^] | 74 | specialArgs = { inherit base; }; |
Skyler Grey | 4f3e606 | 2023-03-04 01:29:29 +0000 | [diff] [blame] | 75 | }; |
Skyler Grey | 07584fb | 2023-05-01 21:37:13 +0000 | [diff] [blame] | 76 | |
| 77 | deploy.nodes.clicks = { |
| 78 | sudo = "doas -u"; |
| 79 | profiles = { |
| 80 | system = { |
| 81 | remoteBuild = true; |
| 82 | user = "root"; |
| 83 | path = deploy-rs.lib.x86_64-linux.activate.nixos |
| 84 | self.nixosConfigurations.clicks; |
| 85 | }; |
| 86 | } // ( |
| 87 | let |
| 88 | mkServiceConfig = service: { |
| 89 | remoteBuild = true; |
| 90 | user = service; |
| 91 | |
| 92 | profilePath = "/nix/var/nix/profiles/per-user/${service}/home-manager"; |
| 93 | path = |
| 94 | deploy-rs.lib.x86_64-linux.activate.home-manager (home-manager.lib.homeManagerConfiguration |
| 95 | { |
| 96 | inherit pkgs; |
| 97 | modules = [ |
| 98 | { |
| 99 | home.homeDirectory = "/services/${service}"; |
| 100 | home.username = service; |
| 101 | home.stateVersion = "22.11"; |
| 102 | programs.home-manager.enable = true; |
| 103 | } |
| 104 | "${./services}/${service}" |
| 105 | ]; |
| 106 | }); |
| 107 | }; |
| 108 | in |
| 109 | nixpkgs.lib.pipe ./services [ |
| 110 | builtins.readDir |
| 111 | (nixpkgs.lib.filterAttrs (_name: value: value == "directory")) |
| 112 | builtins.attrNames |
| 113 | (map (name: { |
| 114 | inherit name; value = mkServiceConfig name; |
| 115 | })) |
| 116 | builtins.listToAttrs |
| 117 | ] |
| 118 | ); |
| 119 | hostname = "clicks"; |
| 120 | profilesOrder = [ "system" ]; |
Skyler Grey | 1e2187f | 2023-03-03 22:45:10 +0000 | [diff] [blame] | 121 | }; |
Skyler Grey | 1e2187f | 2023-03-03 22:45:10 +0000 | [diff] [blame] | 122 | |
Skyler Grey | 07584fb | 2023-05-01 21:37:13 +0000 | [diff] [blame] | 123 | formatter.x86_64-linux = nixpkgs.legacyPackages.x86_64-linux.nixpkgs-fmt; |
Skyler Grey | 1e2187f | 2023-03-03 22:45:10 +0000 | [diff] [blame] | 124 | }; |
Skyler Grey | 1e2187f | 2023-03-03 22:45:10 +0000 | [diff] [blame] | 125 | } |