blob: a751d25914e179f010b656c44c36885631cb0b02 [file] [log] [blame]
Skyler Turner205aff12021-12-20 11:22:57 +00001# Edit this configuration file to define what should be installed on
2# your system. Help is available in the configuration.nix(5) man page
3# and in the NixOS manual (accessible by running ‘nixos-help’).
4
5{ config, pkgs, lib, ... }:
6
Skyler Turner0872be92022-01-24 11:31:38 +00007{
Skyler Turner205aff12021-12-20 11:22:57 +00008 imports =
9 [ # Include the results of the hardware scan.
10 ./hardware-configuration.nix
Skyler Turner444ffc22021-12-20 11:28:06 +000011 ../secrets/networking-configuration.nix
Skyler Turner205aff12021-12-20 11:22:57 +000012 ./packaging-configuration.nix
Skyler Turner657b0492022-02-06 21:42:02 +000013 ./containerd/containerd.nix
Skyler Turner205aff12021-12-20 11:22:57 +000014 ];
15
Skyler Turner32dbfb42021-12-24 15:50:22 +000016 # Prepare nix flakes
17 nix = {
18 package = pkgs.nixFlakes;
19 extraOptions = ''
20 experimental-features = nix-command flakes
21 '';
22 };
23
Skyler Turner205aff12021-12-20 11:22:57 +000024 # Use the systemd-boot EFI boot loader.
25 boot.loader.systemd-boot.enable = true;
26 boot.loader.efi.canTouchEfiVariables = true;
27 boot.loader.grub.useOSProber = true;
28
Skyler Turner7b0051e2021-12-29 15:46:56 +000029 # Enable emulated systems
Skyler Turner107ae412021-12-29 18:34:59 +000030 boot.binfmt.emulatedSystems = [ "aarch64-linux" "armv6l-linux" ];
Skyler Turner7b0051e2021-12-29 15:46:56 +000031
Skyler Turner205aff12021-12-20 11:22:57 +000032 # Enable apparmor
33 security.apparmor.enable = true;
34 security.apparmor.killUnconfinedConfinables = true;
35
36 # Set your time zone.
37 time.timeZone = "Europe/London";
38
39 # Select internationalisation properties.
40 i18n.defaultLocale = "en_US.UTF-8";
41 console = {
42 font = "Lat2-Terminus16";
43 keyMap = "uk";
44 };
45
46 # Enable the X11 windowing system.
47 services.xserver = {
48 enable = true;
49 desktopManager = {
50 xterm.enable = false;
51 # xfce.enable = true;
52 };
Skyler Turner27ee4cb2022-03-06 22:29:09 +000053 displayManager.startx.enable = true;
54 # displayManager.sddm.enable = true;
Skyler Turner205aff12021-12-20 11:22:57 +000055 };
56
Skyler Turner072db1e2022-02-27 01:01:59 +000057 services = {
58 syncthing = {
59 enable = true;
60 user = "minion";
61 dataDir = "/home/minion/Documents"; # Default folder for new synced folders
62 configDir = "/home/minion/.config/syncthing"; # Folder for Syncthing's settings and keys
63 };
64 };
65
Skyler Turner205aff12021-12-20 11:22:57 +000066 # And wayland
Skyler Turner27ee4cb2022-03-06 22:29:09 +000067/* programs.sway = {
Skyler Turner205aff12021-12-20 11:22:57 +000068 enable = true;
69 wrapperFeatures.gtk = true; # so that gtk works properly
70 extraPackages = with pkgs; [
71 swaylock
72 swayidle
73 wl-clipboard
74 mako # notification daemon
75 alacritty # Alacritty is the default terminal in the config
Skyler Turner205aff12021-12-20 11:22:57 +000076 ];
Skyler Turner27ee4cb2022-03-06 22:29:09 +000077 };*/
Skyler Turner205aff12021-12-20 11:22:57 +000078
Skyler Turneref649b02022-02-06 16:05:24 +000079 programs.qt5ct.enable = true;
Skyler Turner27ee4cb2022-03-06 22:29:09 +000080# programs.waybar.enable = false; # true;
Skyler Turnere24f21c2022-02-06 16:02:53 +000081
Skyler Turner205aff12021-12-20 11:22:57 +000082 # Get screensharing to work
83 xdg = {
84 portal = {
85 enable = true;
86 extraPortals = with pkgs; [
87 xdg-desktop-portal-wlr
88 xdg-desktop-portal-gtk
89 ];
90 gtkUsePortal = true;
Skyler Turner84ec77c2022-01-14 09:05:57 +000091 wlr.enable = true;
92
Skyler Turner205aff12021-12-20 11:22:57 +000093 };
94 };
95
Skyler Turner69ca44c2022-03-09 06:56:20 +000096 systemd.user.services.xdg-desktop-portal = {
97 unitConfig = {
98 After = "graphical-session.target";
99 };
100 };
101
Skyler Turner205aff12021-12-20 11:22:57 +0000102 # Configure keymap in X11
103 services.xserver.layout = "gb";
104 # services.xserver.xkbOptions = "eurosign:e";
Skyler Turner55c8ee82022-03-08 19:22:16 +0000105 services.upower.enable = true;
Skyler Turner205aff12021-12-20 11:22:57 +0000106
107 # Permit and install steam
108 nixpkgs.config.allowUnfreePredicate = pkg: builtins.elem (lib.getName pkg) [
109 "steam"
110 "steam-original"
111 "steam-runtime"
112 ];
113
114 programs.steam.enable = true;
115
116
117 # Enable CUPS to print documents.
118 services.printing.enable = true;
119
120 # Enable sound.
121 sound.enable = true;
122 hardware.pulseaudio.enable = false;
123 services.pipewire = {
124 enable = true;
125 alsa = {
126 enable = true;
127 support32Bit = true;
128 };
129 pulse.enable = true;
Skyler Turner4ca71fb2022-02-20 11:12:22 +0000130 /*config.pipewire = {
Skyler Turner074765b2022-02-20 10:46:58 +0000131 "context.modules" = [
Skyler Turner2f6b3ed2022-02-19 14:37:14 +0000132 {
Skyler Turner074765b2022-02-20 10:46:58 +0000133 name = "libpipewire-module-filter-chain";
134 args = {
135 "node.name" = "effect_output.virtual-surround-7.1-hesuvi";
136 "node.description" = "Virtual Surround Sink";
137 "media.name" = "Virtual Surround Sink";
138 nodes = [
139 # duplicate inputs
140 { type = "builtin"; label = "copy"; name = "copyFL"; }
141 { type = "builtin"; label = "copy"; name = "copyFR"; }
142 { type = "builtin"; label = "copy"; name = "copyFC"; }
143 { type = "builtin"; label = "copy"; name = "copyRL"; }
144 { type = "builtin"; label = "copy"; name = "copyRR"; }
145 { type = "builtin"; label = "copy"; name = "copySL"; }
146 { type = "builtin"; label = "copy"; name = "copySR"; }
147 { type = "builtin"; label = "copy"; name = "copyLFE"; }
148
Skyler Turner4ca71fb2022-02-20 11:12:22 +0000149 # apply hrir - HeSuVi 14-channel WAV (not the *-.wav variants) (note: 44 in HeSuVi are the same, but resampled to 44100)
Skyler Turner074765b2022-02-20 10:46:58 +0000150 { type = "builtin"; label = "convolver"; name = "convFL_L"; config = { filename = "hrir_hesuvi/hrir.wav"; channel = 0; }; }
151 { type = "builtin"; label = "convolver"; name = "convFL_R"; config = { filename = "hrir_hesuvi/hrir.wav"; channel = 1; }; }
152 { type = "builtin"; label = "convolver"; name = "convSL_L"; config = { filename = "hrir_hesuvi/hrir.wav"; channel = 2; }; }
153 { type = "builtin"; label = "convolver"; name = "convSL_R"; config = { filename = "hrir_hesuvi/hrir.wav"; channel = 3; }; }
154 { type = "builtin"; label = "convolver"; name = "convRL_L"; config = { filename = "hrir_hesuvi/hrir.wav"; channel = 4; }; }
155 { type = "builtin"; label = "convolver"; name = "convRL_R"; config = { filename = "hrir_hesuvi/hrir.wav"; channel = 5; }; }
156 { type = "builtin"; label = "convolver"; name = "convFC_L"; config = { filename = "hrir_hesuvi/hrir.wav"; channel = 6; }; }
157 { type = "builtin"; label = "convolver"; name = "convFR_R"; config = { filename = "hrir_hesuvi/hrir.wav"; channel = 7; }; }
158 { type = "builtin"; label = "convolver"; name = "convFR_L"; config = { filename = "hrir_hesuvi/hrir.wav"; channel = 8; }; }
159 { type = "builtin"; label = "convolver"; name = "convSR_R"; config = { filename = "hrir_hesuvi/hrir.wav"; channel = 9; }; }
160 { type = "builtin"; label = "convolver"; name = "convSR_L"; config = { filename = "hrir_hesuvi/hrir.wav"; channel = 10; }; }
161 { type = "builtin"; label = "convolver"; name = "convRR_R"; config = { filename = "hrir_hesuvi/hrir.wav"; channel = 11; }; }
162 { type = "builtin"; label = "convolver"; name = "convRR_L"; config = { filename = "hrir_hesuvi/hrir.wav"; channel = 12; }; }
163 { type = "builtin"; label = "convolver"; name = "convFC_R"; config = { filename = "hrir_hesuvi/hrir.wav"; channel = 13; }; }
164
165 # treat LFE as FC
166 { type = "builtin"; label = "convolver"; name = "convLFE_R"; config = { filename = "hrir_hesuvi/hrir.wav"; channel = 13; }; }
167 { type = "builtin"; label = "convolver"; name = "convLFE_L"; config = { filename = "hrir_hesuvi/hrir.wav"; channel = 6; }; }
168
169 # stereo output
170 { type = "builtin"; label = "mixer"; name = "mixR"; }
171 { type = "builtin"; label = "mixer"; name = "mixL"; }
172 ];
173 links = [
174 # input
175 { output = "copyFL:Out"; input="convFL_L:In"; }
176 { output = "copyFL:Out"; input="convFL_R:In"; }
177 { output = "copySL:Out"; input="convSL_L:In"; }
178 { output = "copySL:Out"; input="convSL_R:In"; }
179 { output = "copyRL:Out"; input="convRL_L:In"; }
180 { output = "copyRL:Out"; input="convRL_R:In"; }
181 { output = "copyFC:Out"; input="convFC_L:In"; }
182 { output = "copyFR:Out"; input="convFR_R:In"; }
183 { output = "copyFR:Out"; input="convFR_L:In"; }
184 { output = "copySR:Out"; input="convSR_R:In"; }
185 { output = "copySR:Out"; input="convSR_L:In"; }
186 { output = "copyRR:Out"; input="convRR_R:In"; }
187 { output = "copyRR:Out"; input="convRR_L:In"; }
188 { output = "copyFC:Out"; input="convFC_R:In"; }
189 { output = "copyLFE:Out"; input="convLFE_L:In"; }
190 { output = "copyLFE:Out"; input="convLFE_R:In"; }
191
192 # output
193 { output = "convFL_L:Out"; input="mixL:In 1"; }
194 { output = "convFL_R:Out"; input="mixR:In 1"; }
195 { output = "convSL_L:Out"; input="mixL:In 2"; }
196 { output = "convSL_R:Out"; input="mixR:In 2"; }
197 { output = "convRL_L:Out"; input="mixL:In 3"; }
198 { output = "convRL_R:Out"; input="mixR:In 3"; }
199 { output = "convFC_L:Out"; input="mixL:In 4"; }
200 { output = "convFC_R:Out"; input="mixR:In 4"; }
201 { output = "convFR_R:Out"; input="mixR:In 5"; }
202 { output = "convFR_L:Out"; input="mixL:In 5"; }
203 { output = "convSR_R:Out"; input="mixR:In 6"; }
204 { output = "convSR_L:Out"; input="mixL:In 6"; }
205 { output = "convRR_R:Out"; input="mixR:In 7"; }
206 { output = "convRR_L:Out"; input="mixL:In 7"; }
207 { output = "convLFE_R:Out"; input="mixR:In 8"; }
208 { output = "convLFE_L:Out"; input="mixL:In 8"; }
209 ];
210 inputs = [ "copyFL:In" "copyFR:In" "copyFC:In" "copyLFE:In" "copyRL:In" "copyRR:In" "copySL:In" "copySR:In" ];
211 outputs = [ "mixL:Out" "mixR:Out" ];
212 };
213 "capture.props" = {
214 "media.class" = "Audio/Sink";
215 "audio.channels" = 8;
216 "audio.position" = [ "FL" "FR" "FC" "LFE" "RL" "RR" "SL" "SR" ];
217 };
218 "playback.props" = {
219 "node.passive" = true;
220 "audio.channels" = 2;
221 "audio.position" = [ "FL" "FR" ];
222 };
Skyler Turner2f6b3ed2022-02-19 14:37:14 +0000223 }
224 ];
Skyler Turner4ca71fb2022-02-20 11:12:22 +0000225 };*/
Skyler Turner205aff12021-12-20 11:22:57 +0000226 };
Skyler Turner2f6b3ed2022-02-19 14:37:14 +0000227 environment.etc."pipewire/7.1-surround-sound.conf".source = ./pipewire/7.1-surround-sound.conf;
Skyler Turner205aff12021-12-20 11:22:57 +0000228
Skyler Turner716da2d2022-02-20 20:40:02 +0000229 hardware.openrazer.enable = true;
230 hardware.openrazer.users = [ "minion" ];
231
Skyler Turner205aff12021-12-20 11:22:57 +0000232 # Enable touchpad support (enabled default in most desktopManager).
233 services.xserver.libinput.enable = true;
234
Skyler Turnerbe543712022-03-08 19:21:06 +0000235 programs.dconf.enable = true;
Skyler Turner7145c2d2022-03-08 19:19:10 +0000236
Skyler Turner205aff12021-12-20 11:22:57 +0000237 # Define a user account. Don't forget to set a password with ‘passwd’.
238 users.users.minion = {
239 isNormalUser = true;
Skyler Turnere9893c92022-03-13 15:37:58 +0000240 extraGroups = [ "wheel" "kvm" "docker" "containerd" "dialout" "libvirtd" ]; # Enable ‘sudo’ for the user.
Skyler Turner7fe8a242022-02-06 00:42:28 +0000241 shell = pkgs.zsh;
Skyler Turner205aff12021-12-20 11:22:57 +0000242 };
243
244 # List packages installed in system profile. To search, run:
245 # $ nix search wget
Skyler Turnera3ab14b2022-01-24 11:37:41 +0000246 environment.systemPackages = with pkgs; [
Skyler Turner205aff12021-12-20 11:22:57 +0000247 vim # Do not forget to add an editor to edit configuration.nix! The Nano editor is also installed by default.
248 ((emacsPackagesNgGen emacs).emacsWithPackages (epkgs: [
249 epkgs.vterm
250 epkgs.emacsql-sqlite
251 ])) # Emacs + vterm-module (needed for vterm)
252 wget
253 firefox
254 chromium # Install chromium if needed
255 texlive.combined.scheme-full
Skyler Turner205aff12021-12-20 11:22:57 +0000256 keybase-gui
Skyler Turneree73be42022-01-10 11:02:46 +0000257 bluez
Skyler Turner1a7d0b42022-01-18 10:27:32 +0000258 macchanger
Skyler Turnerb4541be2022-01-21 19:38:55 +0000259 comic-relief
Skyler Turnerb408dcf2022-02-04 23:48:08 +0000260 qemu_kvm
Skyler Turner5954aae2022-02-06 16:03:51 +0000261 polkit_gnome
Skyler Turner785a8a62022-02-06 16:12:59 +0000262 gtk-engine-murrine
263 gtk_engines
264 gsettings-desktop-schemas
265 lxappearance
Skyler Turnerbfe0f542022-02-06 21:45:00 +0000266 ] ++ (import ./containerd/systemPackages.nix pkgs).systemPackages;
Skyler Turner205aff12021-12-20 11:22:57 +0000267
268# environment.systemPackages = [
269# import /scripts/jetbrains.rider.nix
270# ];
271
272 fonts.fonts = with pkgs; [
273 nerdfonts
274 noto-fonts
275 noto-fonts-cjk
276 noto-fonts-emoji
277 liberation_ttf
278 fira-code
279 fira-code-symbols
280 mplus-outline-fonts
281 dina-font
282 proggyfonts
283 roboto
284 ];
285
286 # Some programs need SUID wrappers, can be configured further or are
287 # started in user sessions.
288 programs.mtr.enable = true;
Skyler Turnerf2a29ee2022-02-05 23:39:37 +0000289 programs.kdeconnect.enable = true;
Skyler Turner205aff12021-12-20 11:22:57 +0000290 programs.gnupg.agent = {
291 enable = true;
292 enableSSHSupport = true;
293 };
294
295 # List services that you want to enable:
296
297 # Enable the OpenSSH daemon.
298 services.openssh.enable = true;
299 services.keybase.enable = true;
Skyler Turnera6cfb632022-01-16 23:03:43 +0000300 services.kbfs.enable = true;
301 services.kbfs.enableRedirector = true;
Skyler Turnercde828a2022-02-02 09:41:56 +0000302 security.wrappers.keybase-redirector.owner = "root";
Skyler Turnera620ae92022-02-24 08:26:31 +0000303 security.wrappers.keybase-redirector.group = "users";
Skyler Turner205aff12021-12-20 11:22:57 +0000304 services.gnome.gnome-keyring.enable = true;
305 services.i2p.enable = true;
Skyler Turner87637252022-02-01 12:28:51 +0000306 services.tlp.enable = true;
Skyler Turner67c6fd82022-03-15 17:42:30 +0000307
308 services.udev.extraRules = ''
309 KERNEL=="hidraw*", SUBSYSTEM=="hidraw", MODE="0664", GROUP="plugdev"
310 '';
311
Skyler Turner32dbfb42021-12-24 15:50:22 +0000312 virtualisation.docker.enable = true;
Skyler Turnerf2a29ee2022-02-05 23:39:37 +0000313 virtualisation.docker.enableOnBoot = false;
Skyler Turnere9893c92022-03-13 15:37:58 +0000314 virtualisation.libvirtd.enable = true;
315 virtualisation.libvirtd.onBoot = "ignore";
Skyler Turner205aff12021-12-20 11:22:57 +0000316
Skyler Turnerfff67b52022-02-08 21:29:33 +0000317 hardware.bluetooth.enable = true;
318
Skyler Turner5954aae2022-02-06 16:03:51 +0000319 environment.pathsToLink = [ "/share/zsh" "/libexec" ];
Skyler Turner1035c8c2022-02-05 23:43:34 +0000320
Skyler Turner98483702022-02-04 23:25:21 +0000321 virtualisation.libvirtd.qemu.package = pkgs.qemu_kvm;
Skyler Turner2ee83f82022-02-04 23:18:51 +0000322 virtualisation.kvmgt.enable = true;
323
Skyler Turnerff2168b2022-01-16 16:19:50 +0000324 services.openvpn.servers = {
Skyler Turner3a7d7792022-01-16 16:23:50 +0000325 clicks = { config = '' config /home/minion/Nix/secrets/clicks/client.ovpn ''; };
Skyler Turnerff2168b2022-01-16 16:19:50 +0000326 };
327
Skyler Turnerdf40c9e2022-03-09 09:35:42 +0000328 environment.etc = {
329 "pam.d/swaylock" = {
Skyler Turnerbaa75622022-03-09 09:39:26 +0000330 mode = "0644";
Skyler Turnerdf40c9e2022-03-09 09:35:42 +0000331 text = ''
332 auth include login
333 '';
334 };
335 };
336
Skyler Turner4f5f11b2022-01-14 23:36:39 +0000337 nixpkgs.overlays = [
338 (self: super: {
339 polkit = super.polkit.overrideAttrs (oldAttrs: {
340 patches = oldAttrs.patches ++ [
341 (super.fetchpatch {
342 url = "https://gitlab.freedesktop.org/polkit/polkit/-/commit/716a273ce0af467968057f3e107156182bd290b0.patch";
343 sha256 = "sha256-hOJJhUmxXm87W1ZU9Y1NJ8GCyKvPjbIVtCHlhRGlN8k=";
344 })];
345 });
346 })
347 ];
348
Skyler Turnerb0362522022-02-25 09:36:23 +0000349 xdg.mime.defaultApplications = {
350 "text/html" = "chromium-browser.desktop";
351 "x-scheme-handler/http" = "chromium-browser.desktop";
352 "x-scheme-handler/https" = "chromium-browser.desktop";
353 "x-scheme-handler/about" = "chromium-browser.desktop";
354 "x-scheme-handler/unknown" = "chromium-browser.desktop";
355 };
356
Skyler Turner95f68502022-02-25 09:57:21 +0000357 # environment.sessionsVariables.DEFAULT_BROWSER = "${pkgs.chromium}/bin/chromium";
Skyler Turnerb0362522022-02-25 09:36:23 +0000358
359
Skyler Turner95f68502022-02-25 09:57:21 +0000360 boot.supportedFilesystems = [ "kbfs" ];
361
Skyler Turner205aff12021-12-20 11:22:57 +0000362 # This value determines the NixOS release from which the default
363 # settings for stateful data, like file locations and database versions
364 # on your system were taken. It‘s perfectly fine and recommended to leave
365 # this value at the release version of the first install of this system.
366 # Before changing this value read the documentation for this option
367 # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
368 system.stateVersion = "21.11"; # Did you read the comment?
369
370}
371