Skyler Grey | ffc104a | 2022-05-24 08:47:15 +0100 | [diff] [blame] | 1 | # Modified from https://github.com/gytis-ivaskevicius/nixfiles/blob/5439c8f4d7ccaeed57150846b1ed8afa0b7063ed/overlays/default.nix, which is licensed under the MIT license |
| 2 | # Below is a copy of that license: |
| 3 | /* |
| 4 | MIT License |
| 5 | |
| 6 | Copyright (c) 2021 Gytis Ivaskevicius |
| 7 | |
| 8 | Permission is hereby granted, free of charge, to any person obtaining a copy |
| 9 | of this software and associated documentation files (the "Software"), to deal |
| 10 | in the Software without restriction, including without limitation the rights |
| 11 | to use, copy, modify, merge, publish, distribute, sublicense, and/or sell |
| 12 | copies of the Software, and to permit persons to whom the Software is |
| 13 | furnished to do so, subject to the following conditions: |
| 14 | |
| 15 | The above copyright notice and this permission notice shall be included in all |
| 16 | copies or substantial portions of the Software. |
| 17 | |
| 18 | THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR |
| 19 | IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, |
| 20 | FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE |
| 21 | AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER |
| 22 | LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, |
| 23 | OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE |
| 24 | SOFTWARE. |
| 25 | */ |
| 26 | # Therefore, this file is also copyable under MIT as it represents a "substantial portion" of the original code |
| 27 | |
| 28 | final: prev: { |
| 29 | discord = final.makeDesktopItem { |
| 30 | name = "Discord"; |
Skyler Grey | 6be95aa | 2022-05-24 10:00:59 +0100 | [diff] [blame] | 31 | desktopName = "Discord"; |
Skyler Grey | ffc104a | 2022-05-24 08:47:15 +0100 | [diff] [blame] | 32 | genericName = "All-in-one cross-platform voice and text chat for gamers"; |
Skyler Grey | 150ac0b | 2022-05-24 21:58:02 +0100 | [diff] [blame] | 33 | exec = "${final.chromium}/bin/chromium --app=\"https://discord.com/channels/@me\" --autoplay-policy=no-user-gesture-required --enable-features=WebUIDarkMode --force-dark-mode"; |
Skyler Grey | ffc104a | 2022-05-24 08:47:15 +0100 | [diff] [blame] | 34 | icon = "discord"; |
| 35 | type = "Application"; |
Skyler Grey | 9444ac2 | 2022-05-31 08:54:30 +0100 | [diff] [blame] | 36 | categories = [ "Network" "InstantMessaging" ]; |
Skyler Grey | a220d57 | 2022-05-31 08:55:59 +0100 | [diff] [blame] | 37 | terminal = false; |
Skyler Grey | e35b1b2 | 2022-05-31 08:40:24 +0100 | [diff] [blame] | 38 | mimeTypes=["x-scheme-handler/discord"]; |
Skyler Grey | ffc104a | 2022-05-24 08:47:15 +0100 | [diff] [blame] | 39 | }; |
| 40 | |
Skyler Grey | 4a86fe7 | 2022-05-24 09:55:22 +0100 | [diff] [blame] | 41 | element-desktop-wayland = final.makeDesktopItem { |
Skyler Grey | ffc104a | 2022-05-24 08:47:15 +0100 | [diff] [blame] | 42 | name = "Element"; |
| 43 | desktopName = "Element"; |
| 44 | genericName = "Secure and independent communication, connected via Matrix"; |
Skyler Grey | 150ac0b | 2022-05-24 21:58:02 +0100 | [diff] [blame] | 45 | exec = "${final.chromium}/bin/chromium --app=\"https://app.element.io/#/home\" --autoplay-policy=no-user-gesture-required --enable-features=WebUIDarkMode --force-dark-mode"; |
Skyler Grey | ffc104a | 2022-05-24 08:47:15 +0100 | [diff] [blame] | 46 | icon = "element"; |
| 47 | type = "Application"; |
Skyler Grey | 9444ac2 | 2022-05-31 08:54:30 +0100 | [diff] [blame] | 48 | categories = [ "Network" "InstantMessaging" ]; |
Skyler Grey | a220d57 | 2022-05-31 08:55:59 +0100 | [diff] [blame] | 49 | terminal = false; |
Skyler Grey | ffc104a | 2022-05-24 08:47:15 +0100 | [diff] [blame] | 50 | }; |
| 51 | } |