Skyler Grey | a7feb6e | 2022-08-26 06:51:55 +0100 | [diff] [blame^] | 1 | {pkgs, lib, ...}: { |
2 | programs.neovim = { | ||||
3 | extraConfig = '' | ||||
4 | source ${./git-conflict.lua} | ||||
5 | '' + lib.pipe [ | ||||
6 | ./lazygit.vim | ||||
7 | ] [ | ||||
8 | (map builtins.readFile) | ||||
9 | (builtins.concatStringsSep "\n") | ||||
10 | ]; | ||||
11 | plugins = with pkgs.vimPlugins; [ | ||||
12 | vim-gitgutter | ||||
13 | vim-fugitive | ||||
14 | lazygit-nvim | ||||
15 | pkgs.git-conflict-nvim | ||||
16 | ]; | ||||
17 | }; | ||||
18 | } |