blob: 8ae304fd6ade228836cbced6169d9cff70847384 [file] [log] [blame]
Skyler Grey252927a2022-10-18 22:18:15 +01001{ impermanence, ... }: {
Skyler Grey6aa7c262022-08-20 22:22:03 +01002 imports = [
3 impermanence.nixosModules.impermanence
4 ];
5
6 config = {
7 environment.persistence."/nix/persist" = {
8 hideMounts = true;
9 };
10
Skyler Grey944dfa22022-09-01 23:47:48 +010011 environment.persistence."/large/persist" = {
Skyler Greyb51c0c92022-08-26 06:50:53 +010012 hideMounts = true;
13 };
14
Skyler Grey6aa7c262022-08-20 22:22:03 +010015 fileSystems."/" = {
16 device = "none";
17 fsType = "tmpfs";
Skyler Grey08609332022-10-31 00:31:04 +000018 options = [ "defaults" "size=10G" "mode=755" ];
Skyler Grey6aa7c262022-08-20 22:22:03 +010019 };
Skyler Greyf4a835a2022-08-20 22:30:48 +010020
21 fileSystems."/boot" = {
Skyler Greyb51c0c92022-08-26 06:50:53 +010022 device = "/dev/disk/by-label/BOOT";
Skyler Greyf4a835a2022-08-20 22:30:48 +010023 fsType = "vfat";
24 };
25
26 fileSystems."/nix" = {
Skyler Greyff3c6a22022-08-21 07:25:02 +010027 device = "/dev/mapper/nix";
28 fsType = "ext4";
Skyler Greyb51c0c92022-08-26 06:50:53 +010029 neededForBoot = true;
Skyler Greyff3c6a22022-08-21 07:25:02 +010030 };
31
32 fileSystems."/large" = {
33 device = "/dev/mapper/hdd";
Skyler Grey944dfa22022-09-01 23:47:48 +010034 neededForBoot = true;
Skyler Greyf4a835a2022-08-20 22:30:48 +010035 fsType = "ext4";
36 };
37
38 swapDevices = [
Skyler Grey252927a2022-10-18 22:18:15 +010039 { device = "/dev/mapper/swap"; }
Skyler Greyf4a835a2022-08-20 22:30:48 +010040 ];
Skyler Greyb51c0c92022-08-26 06:50:53 +010041
Skyler Grey252927a2022-10-18 22:18:15 +010042 boot.initrd.availableKernelModules = [ "nvme" ];
Skyler Grey6aa7c262022-08-20 22:22:03 +010043 };
44}