blob: 41a288b8809de25b66ed7a2f156f4f1642d10172 [file] [log] [blame]
Skyler Greyffc104a2022-05-24 08:47:15 +01001# Modified from https://github.com/gytis-ivaskevicius/nixfiles/blob/5439c8f4d7ccaeed57150846b1ed8afa0b7063ed/overlays/default.nix, which is licensed under the MIT license
2# Below is a copy of that license:
3/*
4MIT License
5
6Copyright (c) 2021 Gytis Ivaskevicius
7
8Permission is hereby granted, free of charge, to any person obtaining a copy
9of this software and associated documentation files (the "Software"), to deal
10in the Software without restriction, including without limitation the rights
11to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
12copies of the Software, and to permit persons to whom the Software is
13furnished to do so, subject to the following conditions:
14
15The above copyright notice and this permission notice shall be included in all
16copies or substantial portions of the Software.
17
18THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
19IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
20FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
21AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
22LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
23OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
24SOFTWARE.
25*/
26# Therefore, this file is also copyable under MIT as it represents a "substantial portion" of the original code
27
Skyler Grey76101522022-06-25 21:46:01 +010028final: prev: {}
29/*
Skyler Greyffc104a2022-05-24 08:47:15 +010030 discord = final.makeDesktopItem {
31 name = "Discord";
Skyler Grey6be95aa2022-05-24 10:00:59 +010032 desktopName = "Discord";
Skyler Greyffc104a2022-05-24 08:47:15 +010033 genericName = "All-in-one cross-platform voice and text chat for gamers";
Skyler Grey150ac0b2022-05-24 21:58:02 +010034 exec = "${final.chromium}/bin/chromium --app=\"https://discord.com/channels/@me\" --autoplay-policy=no-user-gesture-required --enable-features=WebUIDarkMode --force-dark-mode";
Skyler Greyffc104a2022-05-24 08:47:15 +010035 icon = "discord";
36 type = "Application";
Skyler Grey9444ac22022-05-31 08:54:30 +010037 categories = [ "Network" "InstantMessaging" ];
Skyler Greya220d572022-05-31 08:55:59 +010038 terminal = false;
Skyler Greye35b1b22022-05-31 08:40:24 +010039 mimeTypes=["x-scheme-handler/discord"];
Skyler Greyffc104a2022-05-24 08:47:15 +010040 };
41
Skyler Grey4a86fe72022-05-24 09:55:22 +010042 element-desktop-wayland = final.makeDesktopItem {
Skyler Greyffc104a2022-05-24 08:47:15 +010043 name = "Element";
44 desktopName = "Element";
45 genericName = "Secure and independent communication, connected via Matrix";
Skyler Grey150ac0b2022-05-24 21:58:02 +010046 exec = "${final.chromium}/bin/chromium --app=\"https://app.element.io/#/home\" --autoplay-policy=no-user-gesture-required --enable-features=WebUIDarkMode --force-dark-mode";
Skyler Greyffc104a2022-05-24 08:47:15 +010047 icon = "element";
48 type = "Application";
Skyler Grey9444ac22022-05-31 08:54:30 +010049 categories = [ "Network" "InstantMessaging" ];
Skyler Greya220d572022-05-31 08:55:59 +010050 terminal = false;
Skyler Greyffc104a2022-05-24 08:47:15 +010051 };
Skyler Grey76101522022-06-25 21:46:01 +010052}*/