Skyler Grey | bcb2cb7 | 2022-08-21 07:24:35 +0100 | [diff] [blame] | 1 | {impermanence, ...}: { |
Skyler Grey | 6aa7c26 | 2022-08-20 22:22:03 +0100 | [diff] [blame] | 2 | imports = [ |
| 3 | impermanence.nixosModules.impermanence |
| 4 | ]; |
| 5 | |
| 6 | config = { |
| 7 | environment.persistence."/nix/persist" = { |
| 8 | hideMounts = true; |
| 9 | }; |
| 10 | |
| 11 | fileSystems."/" = { |
| 12 | device = "none"; |
| 13 | fsType = "tmpfs"; |
| 14 | options = ["defaults" "size=4G" "mode=755"]; |
| 15 | }; |
Skyler Grey | f4a835a | 2022-08-20 22:30:48 +0100 | [diff] [blame] | 16 | |
| 17 | fileSystems."/boot" = { |
| 18 | device = "/dev/disk/by-label/boot"; |
| 19 | fsType = "vfat"; |
| 20 | }; |
| 21 | |
| 22 | fileSystems."/nix" = { |
Skyler Grey | ff3c6a2 | 2022-08-21 07:25:02 +0100 | [diff] [blame] | 23 | device = "/dev/mapper/nix"; |
| 24 | fsType = "ext4"; |
| 25 | }; |
| 26 | |
| 27 | fileSystems."/large" = { |
| 28 | device = "/dev/mapper/hdd"; |
Skyler Grey | f4a835a | 2022-08-20 22:30:48 +0100 | [diff] [blame] | 29 | fsType = "ext4"; |
| 30 | }; |
| 31 | |
| 32 | swapDevices = [ |
Skyler Grey | ff3c6a2 | 2022-08-21 07:25:02 +0100 | [diff] [blame] | 33 | {device = "/dev/mapper/swap";} |
Skyler Grey | f4a835a | 2022-08-20 22:30:48 +0100 | [diff] [blame] | 34 | ]; |
Skyler Grey | 6aa7c26 | 2022-08-20 22:22:03 +0100 | [diff] [blame] | 35 | }; |
| 36 | } |