blob: e493e54dea039febde252bed2bb83136c08ab003 [file] [log] [blame]
Skyler Greya0da6b22024-02-11 22:53:41 +00001{
Samuel Shuert02ffd1e2024-02-13 21:37:15 -05002 description = "The Chimera nix configuration flake, a shared system configuration";
Skyler Greya0da6b22024-02-11 22:53:41 +00003
4 inputs = {
5 nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
6
7 snowfall-lib = {
8 url = "github:snowfallorg/lib";
9 inputs.nixpkgs.follows = "nixpkgs";
10 };
11
12 home-manager = {
13 url = "github:nix-community/home-manager";
14 inputs.nixpkgs.follows = "nixpkgs";
15 };
16
17 nix-index-database = {
18 url = "github:nix-community/nix-index-database";
19 inputs.nixpkgs.follows = "nixpkgs";
20 };
21
22 hyprland.url = "github:hyprwm/Hyprland";
23
24 anyrun = {
25 url = "github:Kirottu/anyrun";
26 inputs.nixpkgs.follows = "nixpkgs";
27 };
28
29 ewwsalmoomedits--eww-widgets = {
30 url = "github:saimoomedits/eww-widgets";
31 flake = false;
32 };
Skyler Grey4e230892024-02-13 22:58:46 +000033
34 nur.url = "github:nix-community/nur";
Skyler Greya0da6b22024-02-11 22:53:41 +000035 };
36
Skyler Grey4e230892024-02-13 22:58:46 +000037 outputs =
38 { self, nixpkgs, ... }@inputs:
Skyler Greya0da6b22024-02-11 22:53:41 +000039 inputs.snowfall-lib.mkFlake {
40 inherit inputs;
41 src = ./.;
42
43 homes.modules = [
44 # TODO: inputs.nix-index-database.hmModules.nix-index
45 ];
46
47 homes.users."minion@greylag".modules = [
48 inputs.hyprland.homeManagerModules.default
49 inputs.anyrun.homeManagerModules.default
Skyler Grey4e230892024-02-13 22:58:46 +000050 inputs.nur.hmModules.nur
Skyler Greya0da6b22024-02-11 22:53:41 +000051 ];
52
53 system.modules.nixos = [
54 inputs.hyprland.nixosModules.default
Samuel Shuert02ffd1e2024-02-13 21:37:15 -050055 inputs.nur.nixosModules.nur
Skyler Greya0da6b22024-02-11 22:53:41 +000056 ];
57
58 snowfall = {
Skyler Grey4e230892024-02-13 22:58:46 +000059 namespace = "chimera";
Skyler Greya0da6b22024-02-11 22:53:41 +000060
Skyler Grey4e230892024-02-13 22:58:46 +000061 meta.name = "chimera";
62 meta.title = "Coded and Minion's Nix Configurations";
Skyler Greya0da6b22024-02-11 22:53:41 +000063 };
64
65 outputs-builder = channels: {
Skyler Grey4e230892024-02-13 22:58:46 +000066 formatter = nixpkgs.legacyPackages.${channels.nixpkgs.system}.nixfmt-rfc-style;
Skyler Greya0da6b22024-02-11 22:53:41 +000067 };
68
69 channels-config = {
70 allowUnfree = true;
71 };
72 };
73}