Skyler Grey | 69a999e | 2024-05-23 00:09:10 +0000 | [diff] [blame] | 1 | { |
| 2 | lib, |
| 3 | config, |
| 4 | ... |
| 5 | }: { |
| 6 | options.chimera = { |
| 7 | wayland.enable = lib.mkOption { |
| 8 | type = lib.types.bool; |
| 9 | description = "Enable generic options which are useful for all wayland compositors"; |
| 10 | default = false; |
| 11 | internal = true; |
| 12 | }; |
| 13 | input.mouse.scrolling.natural = lib.mkEnableOption "Enable natural scrolling"; |
| 14 | input.touchpad.scrolling.natural = lib.mkOption { |
| 15 | type = lib.types.bool; |
| 16 | description = "Enable natural scrolling"; |
| 17 | default = config.chimera.input.mouse.scrolling.natural; |
| 18 | }; |
PineaFan | caf131b | 2024-10-04 20:15:31 +0100 | [diff] [blame] | 19 | input.touchpad.scrolling.factor = lib.mkOption { |
| 20 | type = lib.types.float; |
| 21 | description = "Scrolling factor"; |
| 22 | default = 1; |
| 23 | }; |
| 24 | input.touchpad.tapToClick = lib.mkOption { |
| 25 | type = lib.types.bool; |
| 26 | description = "Enable tap to click"; |
| 27 | default = true; |
| 28 | }; |
| 29 | input.mouse.sensitivity = lib.mkOption { |
| 30 | type = lib.types.float; |
| 31 | description = "Mouse sensitivity"; |
| 32 | default = 1; |
| 33 | }; |
Skyler Grey | 69a999e | 2024-05-23 00:09:10 +0000 | [diff] [blame] | 34 | input.keyboard = { |
| 35 | layout = lib.mkOption { |
| 36 | type = lib.types.str; |
| 37 | description = "Keyboard layouts, comma seperated"; |
| 38 | example = "us,de"; |
| 39 | default = "us"; |
| 40 | }; |
| 41 | variant = lib.mkOption { |
Samuel Shuert | 4d5c5fb | 2024-06-09 09:39:11 -0400 | [diff] [blame] | 42 | type = lib.types.str; |
Skyler Grey | 69a999e | 2024-05-23 00:09:10 +0000 | [diff] [blame] | 43 | description = "Keyboard layout variants, comma seperated"; |
| 44 | example = "dvorak"; |
Samuel Shuert | 4d5c5fb | 2024-06-09 09:39:11 -0400 | [diff] [blame] | 45 | default = ""; |
Skyler Grey | 69a999e | 2024-05-23 00:09:10 +0000 | [diff] [blame] | 46 | }; |
Samuel Shuert | 291d96b | 2024-10-14 14:45:24 -0400 | [diff] [blame^] | 47 | appleMagic = lib.mkEnableOption "Emulate PC keys on Apple Magic Keyboard"; |
Skyler Grey | 69a999e | 2024-05-23 00:09:10 +0000 | [diff] [blame] | 48 | }; |
| 49 | |
| 50 | input.keybinds.alternativeSearch.enable = lib.mkEnableOption "Use alt + space or SUPER + D to open search"; |
| 51 | |
| 52 | nvidia.enable = lib.mkEnableOption "Enable NVIDIA support"; |
| 53 | }; |
| 54 | |
| 55 | config = lib.mkIf config.chimera.wayland.enable { |
| 56 | chimera.waybar.enable = lib.mkDefault true; |
| 57 | chimera.notifications.mako.enable = true; |
| 58 | }; |
| 59 | } |