blob: 5ad25f66d0c760efc0de228b70437c5daa85db9b [file] [log] [blame]
Skyler Grey69a999e2024-05-23 00:09:10 +00001{
2 lib,
3 config,
4 ...
5}: {
6 options.chimera = {
7 wayland.enable = lib.mkOption {
8 type = lib.types.bool;
9 description = "Enable generic options which are useful for all wayland compositors";
10 default = false;
11 internal = true;
12 };
13 input.mouse.scrolling.natural = lib.mkEnableOption "Enable natural scrolling";
14 input.touchpad.scrolling.natural = lib.mkOption {
15 type = lib.types.bool;
16 description = "Enable natural scrolling";
17 default = config.chimera.input.mouse.scrolling.natural;
18 };
PineaFancaf131b2024-10-04 20:15:31 +010019 input.touchpad.scrolling.factor = lib.mkOption {
20 type = lib.types.float;
21 description = "Scrolling factor";
22 default = 1;
23 };
24 input.touchpad.tapToClick = lib.mkOption {
25 type = lib.types.bool;
26 description = "Enable tap to click";
27 default = true;
28 };
29 input.mouse.sensitivity = lib.mkOption {
30 type = lib.types.float;
31 description = "Mouse sensitivity";
32 default = 1;
33 };
Skyler Grey69a999e2024-05-23 00:09:10 +000034 input.keyboard = {
35 layout = lib.mkOption {
36 type = lib.types.str;
37 description = "Keyboard layouts, comma seperated";
38 example = "us,de";
39 default = "us";
40 };
41 variant = lib.mkOption {
Samuel Shuert4d5c5fb2024-06-09 09:39:11 -040042 type = lib.types.str;
Skyler Grey69a999e2024-05-23 00:09:10 +000043 description = "Keyboard layout variants, comma seperated";
44 example = "dvorak";
Samuel Shuert4d5c5fb2024-06-09 09:39:11 -040045 default = "";
Skyler Grey69a999e2024-05-23 00:09:10 +000046 };
Samuel Shuert291d96b2024-10-14 14:45:24 -040047 appleMagic = lib.mkEnableOption "Emulate PC keys on Apple Magic Keyboard";
Skyler Grey69a999e2024-05-23 00:09:10 +000048 };
49
50 input.keybinds.alternativeSearch.enable = lib.mkEnableOption "Use alt + space or SUPER + D to open search";
51
52 nvidia.enable = lib.mkEnableOption "Enable NVIDIA support";
53 };
54
55 config = lib.mkIf config.chimera.wayland.enable {
56 chimera.waybar.enable = lib.mkDefault true;
57 chimera.notifications.mako.enable = true;
58 };
59}