blob: e93f5fd1a8ae87b211b8fd0ef96758f649bd9e24 [file] [log] [blame]
Skyler Greya0da6b22024-02-11 22:53:41 +00001{
Samuel Shuert02ffd1e2024-02-13 21:37:15 -05002 description = "The Chimera nix configuration flake, a shared system configuration";
Skyler Greya0da6b22024-02-11 22:53:41 +00003
4 inputs = {
Skyler Greya0da6b22024-02-11 22:53:41 +00005 anyrun = {
6 url = "github:Kirottu/anyrun";
7 inputs.nixpkgs.follows = "nixpkgs";
8 };
9
10 ewwsalmoomedits--eww-widgets = {
11 url = "github:saimoomedits/eww-widgets";
12 flake = false;
13 };
Skyler Grey4e230892024-02-13 22:58:46 +000014
Samuel Shuert2e42e672024-02-21 21:49:28 +000015 home-manager = {
16 url = "github:nix-community/home-manager";
17 inputs.nixpkgs.follows = "nixpkgs";
18 };
19
20 hyprland.url = "github:hyprwm/Hyprland";
21
22 nix-index-database = {
23 url = "github:nix-community/nix-index-database";
24 inputs.nixpkgs.follows = "nixpkgs";
25 };
26
27 nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
28
Skyler Grey4e230892024-02-13 22:58:46 +000029 nur.url = "github:nix-community/nur";
Samuel Shuert2e42e672024-02-21 21:49:28 +000030
31 snowfall-lib = {
32 url = "github:snowfallorg/lib";
33 inputs.nixpkgs.follows = "nixpkgs";
34 };
35
36 sops-nix.url = "github:Mic92/sops-nix";
Samuel Shuert804f81b2024-02-21 22:20:01 +000037
38 templates.url = "git+https://git.clicks.codes/Templates";
Skyler Greya0da6b22024-02-11 22:53:41 +000039 };
40
Skyler Grey4e230892024-02-13 22:58:46 +000041 outputs =
42 { self, nixpkgs, ... }@inputs:
Samuel Shuertd7ad8db2024-02-20 20:53:34 +000043 let
44 extraHomeModules = [
45 inputs.anyrun.homeManagerModules.default
46 inputs.hyprland.homeManagerModules.default
47 inputs.nur.hmModules.nur
48 ];
49 in inputs.snowfall-lib.mkFlake {
Skyler Greya0da6b22024-02-11 22:53:41 +000050 inherit inputs;
51 src = ./.;
52
Samuel Shuertd7ad8db2024-02-20 20:53:34 +000053 # homes.modules = [
54 # TODO: inputs.nix-index-database.hmModules.nix-index
55 # ];
Skyler Greya0da6b22024-02-11 22:53:41 +000056
Samuel Shuertd7ad8db2024-02-20 20:53:34 +000057 homes.users."coded@shorthair".modules = extraHomeModules;
58
59 homes.users."minion@greylag".modules = extraHomeModules;
60
Samuel Shuert2e42e672024-02-21 21:49:28 +000061 systems.modules.nixos = [
Skyler Greya0da6b22024-02-11 22:53:41 +000062 inputs.hyprland.nixosModules.default
Samuel Shuert02ffd1e2024-02-13 21:37:15 -050063 inputs.nur.nixosModules.nur
Samuel Shuert2e42e672024-02-21 21:49:28 +000064 inputs.sops-nix.nixosModules.sops
Skyler Greya0da6b22024-02-11 22:53:41 +000065 ];
66
67 snowfall = {
Skyler Grey4e230892024-02-13 22:58:46 +000068 namespace = "chimera";
Skyler Greya0da6b22024-02-11 22:53:41 +000069
Skyler Grey4e230892024-02-13 22:58:46 +000070 meta.name = "chimera";
71 meta.title = "Coded and Minion's Nix Configurations";
Skyler Greya0da6b22024-02-11 22:53:41 +000072 };
73
74 outputs-builder = channels: {
Skyler Grey4e230892024-02-13 22:58:46 +000075 formatter = nixpkgs.legacyPackages.${channels.nixpkgs.system}.nixfmt-rfc-style;
Skyler Greya0da6b22024-02-11 22:53:41 +000076 };
77
78 channels-config = {
79 allowUnfree = true;
80 };
81 };
82}