blob: c46ca094eda7d1b3fb38757ff8e71820c8164953 [file] [log] [blame]
Skyler Greya0da6b22024-02-11 22:53:41 +00001{
Skyler Grey4e230892024-02-13 22:58:46 +00002 # Snowfall Lib provides a customized `lib` instance with access to your flake's library
3 # as well as the libraries available from your flake's inputs.
4 lib,
5 # An instance of `pkgs` with your overlays and packages applied is also available.
6 pkgs,
7 # You also have access to your flake's inputs.
8 inputs,
Skyler Greya0da6b22024-02-11 22:53:41 +00009
Skyler Grey4e230892024-02-13 22:58:46 +000010 # Additional metadata is provided by Snowfall Lib.
11 home, # The home architecture for this host (eg. `x86_64-linux`).
12 target, # The Snowfall Lib target for this home (eg. `x86_64-home`).
13 format, # A normalized name for the home target (eg. `home`).
14 virtual, # A boolean to determine whether this home is a virtual target using nixos-generators.
15 host, # The host name for this home.
Skyler Greya0da6b22024-02-11 22:53:41 +000016
Skyler Grey4e230892024-02-13 22:58:46 +000017 # All other arguments come from the home home.
18 config,
19 ...
Skyler Greya0da6b22024-02-11 22:53:41 +000020}:
21{
Skyler Greya2c02ac2024-03-01 21:10:17 +000022 chimera.minion.enable = true;
Skyler Grey82cc5a42024-05-25 00:06:48 +000023 home.packages = [
24 pkgs.wl-clipboard
Skyler Grey889835e2024-05-26 21:23:33 +000025 pkgs.chimera.xwayland-satellite
Skyler Grey82cc5a42024-05-25 00:06:48 +000026 ];
Skyler Greya2c02ac2024-03-01 21:10:17 +000027
28 chimera.waybar = {
29 modules.temperature.hwmonPath = "/sys/class/hwmon/hwmon4/temp1_input";
30 modules.laptop.enable = true;
31 };
32
Skyler Greya2c02ac2024-03-01 21:10:17 +000033 chimera.touchpad.enable = true;
34
Skyler Grey97831642024-05-23 00:09:10 +000035 chimera.hyprland.enable = false;
36 chimera.niri.enable = true;
37 chimera.niri.monitors = {
38 "eDP-1" = {
39 position = {
40 x = 0;
41 y = 0;
42 };
43 };
44 "DP-5" = {
45 position = {
46 x = 2256;
47 y = -1956;
48 };
49 transform.rotation = 90;
50 };
51 "DP-7" = {
52 position = {
53 x = 336;
54 y = -1080;
55 };
56 };
57 };
Skyler Grey0c5b0fc2024-03-03 15:38:44 +000058
Skyler Greya2c02ac2024-03-01 21:10:17 +000059 chimera.theme.wallpaper = ./wallpaper.png;
Skyler Grey4bb9fb32024-02-24 12:23:36 +000060
Skyler Greya2c02ac2024-03-01 21:10:17 +000061 chimera.games = {
62 minecraft.enable = true;
63 itch.enable = true;
Skyler Grey4e230892024-02-13 22:58:46 +000064 };
Skyler Grey2c55d422024-05-25 13:30:43 +000065
66 programs.emacs.package = pkgs.emacs-pgtk;
Skyler Greya0da6b22024-02-11 22:53:41 +000067}