Samuel Shuert | 02ffd1e | 2024-02-13 21:37:15 -0500 | [diff] [blame] | 1 | { config, lib, ... }: |
| 2 | { |
| 3 | options.chimera.editor.neovim = { |
| 4 | enable = lib.mkEnableOption "Enable neovim editor"; |
| 5 | defaultEditor = lib.mkOption { |
| 6 | type = lib.types.bool; |
| 7 | description = "Use neovim as the default editor"; |
| 8 | default = true; |
| 9 | }; |
Samuel Shuert | 659b564 | 2024-02-23 20:47:43 +0000 | [diff] [blame] | 10 | # https://github.com/mrcjkb/kickstart-nix.nvim |
Samuel Shuert | 02ffd1e | 2024-02-13 21:37:15 -0500 | [diff] [blame] | 11 | }; |
| 12 | |
| 13 | config = lib.mkIf config.chimera.editor.neovim.enable { |
| 14 | programs.neovim = { |
| 15 | enable = true; |
| 16 | defaultEditor = config.chimera.editor.neovim.defaultEditor; |
| 17 | }; |
| 18 | }; |
| 19 | } |