blob: c26091064b973ae4b6e41b2efbb1efc8c53d9844 [file] [log] [blame]
Skyler Greya0da6b22024-02-11 22:53:41 +00001{
Skyler Grey4e230892024-02-13 22:58:46 +00002 # Snowfall Lib provides a customized `lib` instance with access to your flake's library
3 # as well as the libraries available from your flake's inputs.
4 lib,
5 # An instance of `pkgs` with your overlays and packages applied is also available.
6 pkgs,
7 # You also have access to your flake's inputs.
8 inputs,
Skyler Greya0da6b22024-02-11 22:53:41 +00009
Skyler Grey4e230892024-02-13 22:58:46 +000010 # Additional metadata is provided by Snowfall Lib.
11 home, # The home architecture for this host (eg. `x86_64-linux`).
12 target, # The Snowfall Lib target for this home (eg. `x86_64-home`).
13 format, # A normalized name for the home target (eg. `home`).
14 virtual, # A boolean to determine whether this home is a virtual target using nixos-generators.
15 host, # The host name for this home.
Skyler Greya0da6b22024-02-11 22:53:41 +000016
Skyler Grey4e230892024-02-13 22:58:46 +000017 # All other arguments come from the home home.
18 config,
19 ...
Skyler Greya0da6b22024-02-11 22:53:41 +000020}:
21{
Samuel Shuertf5136892024-06-20 21:04:47 -040022 chimera.users.minion.enable = true;
Skyler Greyfdc8c272024-09-27 00:38:25 +000023 chimera.nextcloud.enable = true;
24
Skyler Grey82cc5a42024-05-25 00:06:48 +000025 home.packages = [
26 pkgs.wl-clipboard
27 ];
Skyler Greya2c02ac2024-03-01 21:10:17 +000028
29 chimera.waybar = {
30 modules.temperature.hwmonPath = "/sys/class/hwmon/hwmon4/temp1_input";
31 modules.laptop.enable = true;
32 };
33
Skyler Grey02656392024-07-02 21:24:52 +000034 chimera.input.touchpad.enable = true;
Skyler Greya2c02ac2024-03-01 21:10:17 +000035
Skyler Grey69a999e2024-05-23 00:09:10 +000036 chimera.hyprland.enable = false;
37 chimera.niri.enable = true;
38 chimera.niri.monitors = {
39 "eDP-1" = {
40 position = {
41 x = 0;
42 y = 0;
43 };
44 };
45 "DP-5" = {
46 position = {
47 x = 2256;
48 y = -1956;
49 };
50 transform.rotation = 90;
51 };
52 "DP-7" = {
53 position = {
54 x = 336;
55 y = -1080;
56 };
57 };
58 };
Skyler Grey0c5b0fc2024-03-03 15:38:44 +000059
Skyler Greya2c02ac2024-03-01 21:10:17 +000060 chimera.theme.wallpaper = ./wallpaper.png;
Skyler Grey4bb9fb32024-02-24 12:23:36 +000061
Skyler Greya2c02ac2024-03-01 21:10:17 +000062 chimera.games = {
63 minecraft.enable = true;
64 itch.enable = true;
Skyler Grey4e230892024-02-13 22:58:46 +000065 };
Skyler Grey903051b2024-05-25 13:30:43 +000066
67 programs.emacs.package = pkgs.emacs-pgtk;
Skyler Greya0da6b22024-02-11 22:53:41 +000068}