blob: 52a91e623578b333698b4f191515418165e6fc9c [file] [log] [blame]
Skyler Greya0da6b22024-02-11 22:53:41 +00001{
Skyler Grey4e230892024-02-13 22:58:46 +00002 # Snowfall Lib provides a customized `lib` instance with access to your flake's library
3 # as well as the libraries available from your flake's inputs.
4 lib,
5 # An instance of `pkgs` with your overlays and packages applied is also available.
6 pkgs,
7 # You also have access to your flake's inputs.
8 inputs,
Skyler Greya0da6b22024-02-11 22:53:41 +00009
Skyler Grey4e230892024-02-13 22:58:46 +000010 # Additional metadata is provided by Snowfall Lib.
11 home, # The home architecture for this host (eg. `x86_64-linux`).
12 target, # The Snowfall Lib target for this home (eg. `x86_64-home`).
13 format, # A normalized name for the home target (eg. `home`).
14 virtual, # A boolean to determine whether this home is a virtual target using nixos-generators.
15 host, # The host name for this home.
Skyler Greya0da6b22024-02-11 22:53:41 +000016
Skyler Grey4e230892024-02-13 22:58:46 +000017 # All other arguments come from the home home.
18 config,
19 ...
Skyler Greya0da6b22024-02-11 22:53:41 +000020}:
21{
Skyler Greya2c02ac2024-03-01 21:10:17 +000022 chimera.minion.enable = true;
Skyler Grey82cc5a42024-05-25 00:06:48 +000023 home.packages = [
24 pkgs.wl-clipboard
25 ];
Skyler Greya2c02ac2024-03-01 21:10:17 +000026
27 chimera.waybar = {
28 modules.temperature.hwmonPath = "/sys/class/hwmon/hwmon4/temp1_input";
29 modules.laptop.enable = true;
30 };
31
Skyler Greya2c02ac2024-03-01 21:10:17 +000032 chimera.touchpad.enable = true;
33
Skyler Grey97831642024-05-23 00:09:10 +000034 chimera.hyprland.enable = false;
35 chimera.niri.enable = true;
36 chimera.niri.monitors = {
37 "eDP-1" = {
38 position = {
39 x = 0;
40 y = 0;
41 };
42 };
43 "DP-5" = {
44 position = {
45 x = 2256;
46 y = -1956;
47 };
48 transform.rotation = 90;
49 };
50 "DP-7" = {
51 position = {
52 x = 336;
53 y = -1080;
54 };
55 };
56 };
Skyler Grey0c5b0fc2024-03-03 15:38:44 +000057
Skyler Greya2c02ac2024-03-01 21:10:17 +000058 chimera.theme.wallpaper = ./wallpaper.png;
Skyler Grey4bb9fb32024-02-24 12:23:36 +000059
Skyler Greya2c02ac2024-03-01 21:10:17 +000060 chimera.games = {
61 minecraft.enable = true;
62 itch.enable = true;
Skyler Grey4e230892024-02-13 22:58:46 +000063 };
Skyler Grey2c55d422024-05-25 13:30:43 +000064
65 programs.emacs.package = pkgs.emacs-pgtk;
Skyler Greya0da6b22024-02-11 22:53:41 +000066}