blob: 4f7e82140c7ced9c236fa017b7690dbfb3b08d8a [file] [log] [blame]
Skyler Greyf08a6192024-06-01 23:55:20 +00001# SPDX-FileCopyrightText: 2024 Auxolotl Infrastructure Contributors
2# SPDX-FileCopyrightText: 2024 Clicks Codes
3#
4# SPDX-License-Identifier: GPL-3.0-only
5
6{ pkgs, modulesPath, ... }:
7{
8 boot.loader.systemd-boot.enable = true;
9 boot.loader.efi.canTouchEfiVariables = true;
10
11 time.timeZone = "Etc/UTC";
12
13 environment.systemPackages = with pkgs; [ neovim ];
14
15 clicks = {
16 nix.enable = true;
17
18 security = {
19 doas.enable = true;
20
21 acme = {
22 enable = true;
23 email = "minion@clicks.codes";
24 };
25 };
26
27 services = {
28 ssh.enable = true;
29 };
Skyler Grey40ae7a02024-06-06 21:22:25 +000030
31 storage = {
Skyler Greyf4d05f02024-06-06 21:25:39 +000032 raid.enable = true;
Skyler Grey40ae7a02024-06-06 21:22:25 +000033 impermanence = {
34 enable = true;
35 device = "/dev/disk/by-uuid/ab5c2f52-a737-4b29-a505-e3d0b9d0714c";
36 };
37 };
Skyler Greyf08a6192024-06-01 23:55:20 +000038 };
39
40 boot.initrd.availableKernelModules = [
41 "nvme"
42 "xhci_pci"
43 "ahci"
44 "usbhid"
45 "uas"
46 "usb_storage"
47 "sd_mod"
48 ];
49 boot.initrd.kernelModules = [ ];
50 boot.kernelModules = [ "kvm-amd" ];
51 boot.extraModulePackages = [ ];
52
Skyler Grey40ae7a02024-06-06 21:22:25 +000053 fileSystems."/nix" = {
Skyler Greyf08a6192024-06-01 23:55:20 +000054 device = "/dev/disk/by-uuid/ab5c2f52-a737-4b29-a505-e3d0b9d0714c";
55 fsType = "btrfs";
Skyler Grey40ae7a02024-06-06 21:22:25 +000056 options = [ "subvol=@nix" ];
Skyler Greyf08a6192024-06-01 23:55:20 +000057 };
58
59 fileSystems."/boot" = {
60 device = "/dev/disk/by-uuid/880D-BBAB";
61 fsType = "vfat";
62 options = [
63 "fmask=0022"
64 "dmask=0022"
65 ];
66 };
67
68 swapDevices = [ ];
69
70 networking.useDHCP = true;
71
72 system.stateVersion = "24.05";
73}