blob: a44fe0ea3b2db6578ebc8102e297d74c22d0ea77 [file] [log] [blame]
Skyler Grey1010db92022-09-05 03:21:48 +01001{
2 pkgs,
3 lib,
4 ...
5}: {
Skyler Greya7feb6e2022-08-26 06:51:55 +01006 programs.neovim = {
Skyler Grey1010db92022-09-05 03:21:48 +01007 extraConfig =
8 ''
9 source ${./git-conflict.lua}
10 ''
11 + lib.pipe [
12 ./lazygit.vim
13 ] [
14 (map builtins.readFile)
15 (builtins.concatStringsSep "\n")
16 ];
Skyler Greya7feb6e2022-08-26 06:51:55 +010017 plugins = with pkgs.vimPlugins; [
18 vim-gitgutter
19 vim-fugitive
20 lazygit-nvim
21 pkgs.git-conflict-nvim
22 ];
23 };
24}