blob: f66c20e12d5b99f9df1b312f1f24253588290177 [file] [log] [blame]
Skyler Turner205aff12021-12-20 11:22:57 +00001# Edit this configuration file to define what should be installed on
2# your system. Help is available in the configuration.nix(5) man page
3# and in the NixOS manual (accessible by running ‘nixos-help’).
4
5{ config, pkgs, lib, ... }:
6
Skyler Turner0872be92022-01-24 11:31:38 +00007{
Skyler Turner205aff12021-12-20 11:22:57 +00008 imports =
9 [ # Include the results of the hardware scan.
10 ./hardware-configuration.nix
Skyler Turner444ffc22021-12-20 11:28:06 +000011 ../secrets/networking-configuration.nix
Skyler Turner205aff12021-12-20 11:22:57 +000012 ./packaging-configuration.nix
Skyler Turner657b0492022-02-06 21:42:02 +000013 ./containerd/containerd.nix
Skyler Turner205aff12021-12-20 11:22:57 +000014 ];
15
Skyler Turner32dbfb42021-12-24 15:50:22 +000016 # Prepare nix flakes
17 nix = {
18 package = pkgs.nixFlakes;
19 extraOptions = ''
20 experimental-features = nix-command flakes
21 '';
22 };
23
Skyler Turner205aff12021-12-20 11:22:57 +000024 # Use the systemd-boot EFI boot loader.
25 boot.loader.systemd-boot.enable = true;
26 boot.loader.efi.canTouchEfiVariables = true;
27 boot.loader.grub.useOSProber = true;
28
Skyler Turner7b0051e2021-12-29 15:46:56 +000029 # Enable emulated systems
Skyler Turner107ae412021-12-29 18:34:59 +000030 boot.binfmt.emulatedSystems = [ "aarch64-linux" "armv6l-linux" ];
Skyler Turner7b0051e2021-12-29 15:46:56 +000031
Skyler Turner205aff12021-12-20 11:22:57 +000032 # Enable apparmor
33 security.apparmor.enable = true;
34 security.apparmor.killUnconfinedConfinables = true;
35
36 # Set your time zone.
37 time.timeZone = "Europe/London";
38
39 # Select internationalisation properties.
40 i18n.defaultLocale = "en_US.UTF-8";
41 console = {
42 font = "Lat2-Terminus16";
43 keyMap = "uk";
44 };
45
46 # Enable the X11 windowing system.
47 services.xserver = {
48 enable = true;
49 desktopManager = {
50 xterm.enable = false;
51 # xfce.enable = true;
52 };
Skyler Turner27ee4cb2022-03-06 22:29:09 +000053 displayManager.startx.enable = true;
54 # displayManager.sddm.enable = true;
Skyler Turner205aff12021-12-20 11:22:57 +000055 };
56
Skyler Turner072db1e2022-02-27 01:01:59 +000057 services = {
58 syncthing = {
59 enable = true;
60 user = "minion";
61 dataDir = "/home/minion/Documents"; # Default folder for new synced folders
62 configDir = "/home/minion/.config/syncthing"; # Folder for Syncthing's settings and keys
63 };
64 };
65
Skyler Turner205aff12021-12-20 11:22:57 +000066 # And wayland
Skyler Turner27ee4cb2022-03-06 22:29:09 +000067/* programs.sway = {
Skyler Turner205aff12021-12-20 11:22:57 +000068 enable = true;
69 wrapperFeatures.gtk = true; # so that gtk works properly
70 extraPackages = with pkgs; [
71 swaylock
72 swayidle
73 wl-clipboard
74 mako # notification daemon
75 alacritty # Alacritty is the default terminal in the config
Skyler Turner205aff12021-12-20 11:22:57 +000076 ];
Skyler Turner27ee4cb2022-03-06 22:29:09 +000077 };*/
Skyler Turner205aff12021-12-20 11:22:57 +000078
Skyler Turneref649b02022-02-06 16:05:24 +000079 programs.qt5ct.enable = true;
Skyler Turner27ee4cb2022-03-06 22:29:09 +000080# programs.waybar.enable = false; # true;
Skyler Turnere24f21c2022-02-06 16:02:53 +000081
Skyler Turner205aff12021-12-20 11:22:57 +000082 # Get screensharing to work
83 xdg = {
84 portal = {
85 enable = true;
86 extraPortals = with pkgs; [
87 xdg-desktop-portal-wlr
Skyler Turnere8b7af22022-03-21 00:05:17 +000088# xdg-desktop-portal-gtk
89# xdg-desktop-portal-kde
Skyler Turner205aff12021-12-20 11:22:57 +000090 ];
Skyler Turnere8b7af22022-03-21 00:05:17 +000091# gtkUsePortal = true;
Skyler Turner84ec77c2022-01-14 09:05:57 +000092 wlr.enable = true;
93
Skyler Turner205aff12021-12-20 11:22:57 +000094 };
95 };
96
Skyler Turner69ca44c2022-03-09 06:56:20 +000097 systemd.user.services.xdg-desktop-portal = {
98 unitConfig = {
99 After = "graphical-session.target";
100 };
101 };
102
Skyler Turner205aff12021-12-20 11:22:57 +0000103 # Configure keymap in X11
104 services.xserver.layout = "gb";
105 # services.xserver.xkbOptions = "eurosign:e";
Skyler Turner55c8ee82022-03-08 19:22:16 +0000106 services.upower.enable = true;
Skyler Turner205aff12021-12-20 11:22:57 +0000107
108 # Permit and install steam
109 nixpkgs.config.allowUnfreePredicate = pkg: builtins.elem (lib.getName pkg) [
110 "steam"
111 "steam-original"
112 "steam-runtime"
113 ];
114
115 programs.steam.enable = true;
116
117
118 # Enable CUPS to print documents.
119 services.printing.enable = true;
120
121 # Enable sound.
122 sound.enable = true;
123 hardware.pulseaudio.enable = false;
124 services.pipewire = {
125 enable = true;
126 alsa = {
127 enable = true;
128 support32Bit = true;
129 };
130 pulse.enable = true;
Skyler Turner4ca71fb2022-02-20 11:12:22 +0000131 /*config.pipewire = {
Skyler Turner074765b2022-02-20 10:46:58 +0000132 "context.modules" = [
Skyler Turner2f6b3ed2022-02-19 14:37:14 +0000133 {
Skyler Turner074765b2022-02-20 10:46:58 +0000134 name = "libpipewire-module-filter-chain";
135 args = {
136 "node.name" = "effect_output.virtual-surround-7.1-hesuvi";
137 "node.description" = "Virtual Surround Sink";
138 "media.name" = "Virtual Surround Sink";
139 nodes = [
140 # duplicate inputs
141 { type = "builtin"; label = "copy"; name = "copyFL"; }
142 { type = "builtin"; label = "copy"; name = "copyFR"; }
143 { type = "builtin"; label = "copy"; name = "copyFC"; }
144 { type = "builtin"; label = "copy"; name = "copyRL"; }
145 { type = "builtin"; label = "copy"; name = "copyRR"; }
146 { type = "builtin"; label = "copy"; name = "copySL"; }
147 { type = "builtin"; label = "copy"; name = "copySR"; }
148 { type = "builtin"; label = "copy"; name = "copyLFE"; }
149
Skyler Turner4ca71fb2022-02-20 11:12:22 +0000150 # apply hrir - HeSuVi 14-channel WAV (not the *-.wav variants) (note: 44 in HeSuVi are the same, but resampled to 44100)
Skyler Turner074765b2022-02-20 10:46:58 +0000151 { type = "builtin"; label = "convolver"; name = "convFL_L"; config = { filename = "hrir_hesuvi/hrir.wav"; channel = 0; }; }
152 { type = "builtin"; label = "convolver"; name = "convFL_R"; config = { filename = "hrir_hesuvi/hrir.wav"; channel = 1; }; }
153 { type = "builtin"; label = "convolver"; name = "convSL_L"; config = { filename = "hrir_hesuvi/hrir.wav"; channel = 2; }; }
154 { type = "builtin"; label = "convolver"; name = "convSL_R"; config = { filename = "hrir_hesuvi/hrir.wav"; channel = 3; }; }
155 { type = "builtin"; label = "convolver"; name = "convRL_L"; config = { filename = "hrir_hesuvi/hrir.wav"; channel = 4; }; }
156 { type = "builtin"; label = "convolver"; name = "convRL_R"; config = { filename = "hrir_hesuvi/hrir.wav"; channel = 5; }; }
157 { type = "builtin"; label = "convolver"; name = "convFC_L"; config = { filename = "hrir_hesuvi/hrir.wav"; channel = 6; }; }
158 { type = "builtin"; label = "convolver"; name = "convFR_R"; config = { filename = "hrir_hesuvi/hrir.wav"; channel = 7; }; }
159 { type = "builtin"; label = "convolver"; name = "convFR_L"; config = { filename = "hrir_hesuvi/hrir.wav"; channel = 8; }; }
160 { type = "builtin"; label = "convolver"; name = "convSR_R"; config = { filename = "hrir_hesuvi/hrir.wav"; channel = 9; }; }
161 { type = "builtin"; label = "convolver"; name = "convSR_L"; config = { filename = "hrir_hesuvi/hrir.wav"; channel = 10; }; }
162 { type = "builtin"; label = "convolver"; name = "convRR_R"; config = { filename = "hrir_hesuvi/hrir.wav"; channel = 11; }; }
163 { type = "builtin"; label = "convolver"; name = "convRR_L"; config = { filename = "hrir_hesuvi/hrir.wav"; channel = 12; }; }
164 { type = "builtin"; label = "convolver"; name = "convFC_R"; config = { filename = "hrir_hesuvi/hrir.wav"; channel = 13; }; }
165
166 # treat LFE as FC
167 { type = "builtin"; label = "convolver"; name = "convLFE_R"; config = { filename = "hrir_hesuvi/hrir.wav"; channel = 13; }; }
168 { type = "builtin"; label = "convolver"; name = "convLFE_L"; config = { filename = "hrir_hesuvi/hrir.wav"; channel = 6; }; }
169
170 # stereo output
171 { type = "builtin"; label = "mixer"; name = "mixR"; }
172 { type = "builtin"; label = "mixer"; name = "mixL"; }
173 ];
174 links = [
175 # input
176 { output = "copyFL:Out"; input="convFL_L:In"; }
177 { output = "copyFL:Out"; input="convFL_R:In"; }
178 { output = "copySL:Out"; input="convSL_L:In"; }
179 { output = "copySL:Out"; input="convSL_R:In"; }
180 { output = "copyRL:Out"; input="convRL_L:In"; }
181 { output = "copyRL:Out"; input="convRL_R:In"; }
182 { output = "copyFC:Out"; input="convFC_L:In"; }
183 { output = "copyFR:Out"; input="convFR_R:In"; }
184 { output = "copyFR:Out"; input="convFR_L:In"; }
185 { output = "copySR:Out"; input="convSR_R:In"; }
186 { output = "copySR:Out"; input="convSR_L:In"; }
187 { output = "copyRR:Out"; input="convRR_R:In"; }
188 { output = "copyRR:Out"; input="convRR_L:In"; }
189 { output = "copyFC:Out"; input="convFC_R:In"; }
190 { output = "copyLFE:Out"; input="convLFE_L:In"; }
191 { output = "copyLFE:Out"; input="convLFE_R:In"; }
192
193 # output
194 { output = "convFL_L:Out"; input="mixL:In 1"; }
195 { output = "convFL_R:Out"; input="mixR:In 1"; }
196 { output = "convSL_L:Out"; input="mixL:In 2"; }
197 { output = "convSL_R:Out"; input="mixR:In 2"; }
198 { output = "convRL_L:Out"; input="mixL:In 3"; }
199 { output = "convRL_R:Out"; input="mixR:In 3"; }
200 { output = "convFC_L:Out"; input="mixL:In 4"; }
201 { output = "convFC_R:Out"; input="mixR:In 4"; }
202 { output = "convFR_R:Out"; input="mixR:In 5"; }
203 { output = "convFR_L:Out"; input="mixL:In 5"; }
204 { output = "convSR_R:Out"; input="mixR:In 6"; }
205 { output = "convSR_L:Out"; input="mixL:In 6"; }
206 { output = "convRR_R:Out"; input="mixR:In 7"; }
207 { output = "convRR_L:Out"; input="mixL:In 7"; }
208 { output = "convLFE_R:Out"; input="mixR:In 8"; }
209 { output = "convLFE_L:Out"; input="mixL:In 8"; }
210 ];
211 inputs = [ "copyFL:In" "copyFR:In" "copyFC:In" "copyLFE:In" "copyRL:In" "copyRR:In" "copySL:In" "copySR:In" ];
212 outputs = [ "mixL:Out" "mixR:Out" ];
213 };
214 "capture.props" = {
215 "media.class" = "Audio/Sink";
216 "audio.channels" = 8;
217 "audio.position" = [ "FL" "FR" "FC" "LFE" "RL" "RR" "SL" "SR" ];
218 };
219 "playback.props" = {
220 "node.passive" = true;
221 "audio.channels" = 2;
222 "audio.position" = [ "FL" "FR" ];
223 };
Skyler Turner2f6b3ed2022-02-19 14:37:14 +0000224 }
225 ];
Skyler Turner4ca71fb2022-02-20 11:12:22 +0000226 };*/
Skyler Turner205aff12021-12-20 11:22:57 +0000227 };
Skyler Turner2f6b3ed2022-02-19 14:37:14 +0000228 environment.etc."pipewire/7.1-surround-sound.conf".source = ./pipewire/7.1-surround-sound.conf;
Skyler Turner205aff12021-12-20 11:22:57 +0000229
Skyler Turner716da2d2022-02-20 20:40:02 +0000230 hardware.openrazer.enable = true;
231 hardware.openrazer.users = [ "minion" ];
232
Skyler Turner205aff12021-12-20 11:22:57 +0000233 # Enable touchpad support (enabled default in most desktopManager).
234 services.xserver.libinput.enable = true;
235
Skyler Turnerbe543712022-03-08 19:21:06 +0000236 programs.dconf.enable = true;
Skyler Turner7145c2d2022-03-08 19:19:10 +0000237
Skyler Turner205aff12021-12-20 11:22:57 +0000238 # Define a user account. Don't forget to set a password with ‘passwd’.
239 users.users.minion = {
240 isNormalUser = true;
Skyler Turnere9893c92022-03-13 15:37:58 +0000241 extraGroups = [ "wheel" "kvm" "docker" "containerd" "dialout" "libvirtd" ]; # Enable ‘sudo’ for the user.
Skyler Turner7fe8a242022-02-06 00:42:28 +0000242 shell = pkgs.zsh;
Skyler Turner205aff12021-12-20 11:22:57 +0000243 };
244
245 # List packages installed in system profile. To search, run:
246 # $ nix search wget
Skyler Turnera3ab14b2022-01-24 11:37:41 +0000247 environment.systemPackages = with pkgs; [
Skyler Turner205aff12021-12-20 11:22:57 +0000248 vim # Do not forget to add an editor to edit configuration.nix! The Nano editor is also installed by default.
249 ((emacsPackagesNgGen emacs).emacsWithPackages (epkgs: [
250 epkgs.vterm
251 epkgs.emacsql-sqlite
252 ])) # Emacs + vterm-module (needed for vterm)
253 wget
254 firefox
255 chromium # Install chromium if needed
256 texlive.combined.scheme-full
Skyler Turner205aff12021-12-20 11:22:57 +0000257 keybase-gui
Skyler Turneree73be42022-01-10 11:02:46 +0000258 bluez
Skyler Turner1a7d0b42022-01-18 10:27:32 +0000259 macchanger
Skyler Turnerb4541be2022-01-21 19:38:55 +0000260 comic-relief
Skyler Turnerb408dcf2022-02-04 23:48:08 +0000261 qemu_kvm
Skyler Turner5954aae2022-02-06 16:03:51 +0000262 polkit_gnome
Skyler Turner785a8a62022-02-06 16:12:59 +0000263 gtk-engine-murrine
264 gtk_engines
265 gsettings-desktop-schemas
266 lxappearance
Skyler Turnerbfe0f542022-02-06 21:45:00 +0000267 ] ++ (import ./containerd/systemPackages.nix pkgs).systemPackages;
Skyler Turner205aff12021-12-20 11:22:57 +0000268
269# environment.systemPackages = [
270# import /scripts/jetbrains.rider.nix
271# ];
272
273 fonts.fonts = with pkgs; [
274 nerdfonts
275 noto-fonts
276 noto-fonts-cjk
277 noto-fonts-emoji
278 liberation_ttf
279 fira-code
280 fira-code-symbols
281 mplus-outline-fonts
282 dina-font
283 proggyfonts
284 roboto
285 ];
286
287 # Some programs need SUID wrappers, can be configured further or are
288 # started in user sessions.
289 programs.mtr.enable = true;
Skyler Turnerf2a29ee2022-02-05 23:39:37 +0000290 programs.kdeconnect.enable = true;
Skyler Turner205aff12021-12-20 11:22:57 +0000291 programs.gnupg.agent = {
292 enable = true;
293 enableSSHSupport = true;
294 };
295
296 # List services that you want to enable:
297
298 # Enable the OpenSSH daemon.
299 services.openssh.enable = true;
300 services.keybase.enable = true;
Skyler Turnera6cfb632022-01-16 23:03:43 +0000301 services.kbfs.enable = true;
302 services.kbfs.enableRedirector = true;
Skyler Turnercde828a2022-02-02 09:41:56 +0000303 security.wrappers.keybase-redirector.owner = "root";
Skyler Turnera620ae92022-02-24 08:26:31 +0000304 security.wrappers.keybase-redirector.group = "users";
Skyler Turner205aff12021-12-20 11:22:57 +0000305 services.gnome.gnome-keyring.enable = true;
306 services.i2p.enable = true;
Skyler Turner87637252022-02-01 12:28:51 +0000307 services.tlp.enable = true;
Skyler Turner67c6fd82022-03-15 17:42:30 +0000308
Skyler Turner32dbfb42021-12-24 15:50:22 +0000309 virtualisation.docker.enable = true;
Skyler Turnerf2a29ee2022-02-05 23:39:37 +0000310 virtualisation.docker.enableOnBoot = false;
Skyler Turnere9893c92022-03-13 15:37:58 +0000311 virtualisation.libvirtd.enable = true;
312 virtualisation.libvirtd.onBoot = "ignore";
Skyler Turner205aff12021-12-20 11:22:57 +0000313
Skyler Turnerfff67b52022-02-08 21:29:33 +0000314 hardware.bluetooth.enable = true;
315
Skyler Turner5954aae2022-02-06 16:03:51 +0000316 environment.pathsToLink = [ "/share/zsh" "/libexec" ];
Skyler Turner1035c8c2022-02-05 23:43:34 +0000317
Skyler Turner98483702022-02-04 23:25:21 +0000318 virtualisation.libvirtd.qemu.package = pkgs.qemu_kvm;
Skyler Turner2ee83f82022-02-04 23:18:51 +0000319 virtualisation.kvmgt.enable = true;
320
Skyler Turnerff2168b2022-01-16 16:19:50 +0000321 services.openvpn.servers = {
Skyler Turner3a7d7792022-01-16 16:23:50 +0000322 clicks = { config = '' config /home/minion/Nix/secrets/clicks/client.ovpn ''; };
Skyler Turnerff2168b2022-01-16 16:19:50 +0000323 };
324
Skyler Turnerdf40c9e2022-03-09 09:35:42 +0000325 environment.etc = {
326 "pam.d/swaylock" = {
Skyler Turnerbaa75622022-03-09 09:39:26 +0000327 mode = "0644";
Skyler Turnerdf40c9e2022-03-09 09:35:42 +0000328 text = ''
329 auth include login
330 '';
331 };
332 };
333
Skyler Turner4f5f11b2022-01-14 23:36:39 +0000334 nixpkgs.overlays = [
335 (self: super: {
336 polkit = super.polkit.overrideAttrs (oldAttrs: {
337 patches = oldAttrs.patches ++ [
338 (super.fetchpatch {
339 url = "https://gitlab.freedesktop.org/polkit/polkit/-/commit/716a273ce0af467968057f3e107156182bd290b0.patch";
340 sha256 = "sha256-hOJJhUmxXm87W1ZU9Y1NJ8GCyKvPjbIVtCHlhRGlN8k=";
341 })];
342 });
343 })
344 ];
345
Skyler Turnerb0362522022-02-25 09:36:23 +0000346 xdg.mime.defaultApplications = {
347 "text/html" = "chromium-browser.desktop";
348 "x-scheme-handler/http" = "chromium-browser.desktop";
349 "x-scheme-handler/https" = "chromium-browser.desktop";
350 "x-scheme-handler/about" = "chromium-browser.desktop";
351 "x-scheme-handler/unknown" = "chromium-browser.desktop";
352 };
353
Skyler Turner95f68502022-02-25 09:57:21 +0000354 # environment.sessionsVariables.DEFAULT_BROWSER = "${pkgs.chromium}/bin/chromium";
Skyler Turnerb0362522022-02-25 09:36:23 +0000355
356
Skyler Turner95f68502022-02-25 09:57:21 +0000357 boot.supportedFilesystems = [ "kbfs" ];
358
Skyler Turner205aff12021-12-20 11:22:57 +0000359 # This value determines the NixOS release from which the default
360 # settings for stateful data, like file locations and database versions
361 # on your system were taken. It‘s perfectly fine and recommended to leave
362 # this value at the release version of the first install of this system.
363 # Before changing this value read the documentation for this option
364 # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
365 system.stateVersion = "21.11"; # Did you read the comment?
366
367}
368