Samuel Shuert | f1d6e99 | 2023-11-24 17:28:33 -0500 | [diff] [blame] | 1 | { pkgs, config, inputs, ... }: { |
| 2 | programs.zsh.enable = true; |
| 3 | users.users.coded.shell = pkgs.zsh; |
| 4 | |
Samuel Shuert | 80c2dd4 | 2023-12-01 22:03:34 -0500 | [diff] [blame] | 5 | environment.systemPackages = with pkgs; [ |
| 6 | bmon |
| 7 | wget |
Samuel Shuert | f6c41b5 | 2023-12-02 13:21:47 -0500 | [diff] [blame^] | 8 | ripgrep |
Samuel Shuert | 80c2dd4 | 2023-12-01 22:03:34 -0500 | [diff] [blame] | 9 | ]; |
| 10 | |
Samuel Shuert | f1d6e99 | 2023-11-24 17:28:33 -0500 | [diff] [blame] | 11 | home-manager.users.coded.programs = { |
| 12 | # ZSH |
| 13 | zsh = { |
| 14 | enable = true; |
| 15 | enableAutosuggestions = true; |
| 16 | enableCompletion = true; |
| 17 | autocd = true; |
| 18 | defaultKeymap = "emacs"; |
| 19 | |
| 20 | shellAliases = { |
| 21 | rebuild = "sudo nixos-rebuild switch --flake /home/coded/nixConfig/"; |
| 22 | "gr!" = "git review"; |
| 23 | clr = "clear"; |
| 24 | pnpx = "pnpm dlx"; |
Samuel Shuert | 80c2dd4 | 2023-12-01 22:03:34 -0500 | [diff] [blame] | 25 | print3d = "sudo /run/current-system/sw/bin/pronsole.py"; |
| 26 | nh = "wget -O ~/Documents/hashCheck $1 | nix hash file ~/Documents/hashCheck"; |
Samuel Shuert | f6c41b5 | 2023-12-02 13:21:47 -0500 | [diff] [blame^] | 27 | edit = "nvim"; |
| 28 | neovim = "nvim"; |
| 29 | v = "nvim"; |
Samuel Shuert | f1d6e99 | 2023-11-24 17:28:33 -0500 | [diff] [blame] | 30 | }; |
| 31 | |
| 32 | dirHashes = { code = "$HOME/Documents/programming"; }; |
| 33 | |
| 34 | history = { extended = true; }; |
| 35 | historySubstringSearch.enable = true; |
| 36 | |
| 37 | oh-my-zsh = { |
| 38 | enable = true; |
| 39 | plugins = [ "git" ]; |
| 40 | }; |
| 41 | }; |
Samuel Shuert | 80c2dd4 | 2023-12-01 22:03:34 -0500 | [diff] [blame] | 42 | |
Samuel Shuert | f1d6e99 | 2023-11-24 17:28:33 -0500 | [diff] [blame] | 43 | # Starship |
| 44 | starship = { |
| 45 | enable = true; |
| 46 | settings = { format = "$all"; }; |
| 47 | }; |
| 48 | |
| 49 | # Alacritty |
| 50 | alacritty = { |
| 51 | enable = true; |
| 52 | settings = { |
| 53 | window.dimensions = { |
| 54 | lines = 40; |
| 55 | columns = 150; |
| 56 | }; |
| 57 | import = [ |
| 58 | "${inputs.alacritty-themes}/themes/Catppuccin-Mocha.yml" |
| 59 | ]; |
| 60 | }; |
| 61 | }; |
| 62 | |
Samuel Shuert | f1d6e99 | 2023-11-24 17:28:33 -0500 | [diff] [blame] | 63 | # Nix-index |
| 64 | nix-index.enable = true; |
| 65 | |
| 66 | # thefuck |
| 67 | thefuck = { |
| 68 | enable = true; |
| 69 | enableInstantMode = true; |
| 70 | }; |
| 71 | }; |
| 72 | |
| 73 | environment.pathsToLink = |
| 74 | [ "/share/zsh" ]; # needed for completing system packages |
| 75 | } |